summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-06 04:40:35 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-06 05:10:13 +0100
commit8903b6abdd64c8a5cc12b04bc18c11a557067652 (patch)
tree3272a58f13844e355a4ca01346c72ddf9eedd302
parentdev-python/mkdocstrings-python: Bump to 1.14.5 (diff)
downloadgentoo-8903b6abdd64c8a5cc12b04bc18c11a557067652.tar.gz
gentoo-8903b6abdd64c8a5cc12b04bc18c11a557067652.tar.bz2
gentoo-8903b6abdd64c8a5cc12b04bc18c11a557067652.zip
dev-python/ansible-compat: Bump to 25.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-25.1.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 88d1b9bbe9ba..dda620cc6970 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -2,3 +2,4 @@ DIST ansible-compat-24.9.1.gh.tar.gz 76018 BLAKE2B 581199ab65ccc884a3eeef246a8db
DIST ansible_compat-24.10.0.tar.gz 81818 BLAKE2B 78afad41dbe2172cb485186d78a488343391b5feb39f233f8584dc65ece8f290b43c8a6b0112db4606329bc5f38a9e44c6e39fd48efcb5562292152d44276539 SHA512 636ccb66be3570bf7ab0a51f991fefe3b4754db3fddb4d45ebd116de2721082e8ad4049e0cdd975431f01daaa4cb9d24ca57a97913fa66ce1f1f47780734ab14
DIST ansible_compat-25.1.0.tar.gz 87512 BLAKE2B 3547a26cd24656e6b7efc1d5250c3b224d539f08bd4fe1569aa3b2a84123baa0969cf1631d004eaab853b19ecf75a525a2baa6fd179a3737c503734459e78b2d SHA512 81b610f997b5d0fcd348a701e94bf7300175851f8c020af4129d3a95996ae61614004c8286af35f0d64887cdd6ae29ecad4aa22ddca4a9802f85178ebc21830b
DIST ansible_compat-25.1.1.tar.gz 87846 BLAKE2B b38b5dc14a085470f0fccb4c6514fdeff70229606bceec6cf334947c9e4238c42de5afeb357c386df8aab6d671e14d164c38b2d1dfda5a669cb10780c5154cdf SHA512 0132d21993dac321d73148e732e3313fe1f27b30f65a011068956d788cce862344d86094ad55a79e9be10fd8127a8b729bed8a4cc67afde7f9b73dc9306161b9
+DIST ansible_compat-25.1.2.tar.gz 87902 BLAKE2B c2a96fb67c32e8a02d2e1f6c6ddbcbd966fac1e9485f00ba8293ced2fc2de986616a9987772a54d6f5ee1c88cbf9a09fb3b36eed44949b241f50b761ff52d06b SHA512 b07ae461241c3c2ab7b52b519ab773ecb878b6cd24353a81187c5aeb14c332af5f666d5034b8972e6bbedc9a0cd761c887492064a122593cc8746702ffc83adc
diff --git a/dev-python/ansible-compat/ansible-compat-25.1.2.ebuild b/dev-python/ansible-compat/ansible-compat-25.1.2.ebuild
new file mode 100644
index 000000000000..5d0bd8248da6
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-25.1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.23.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # All these tests attempt to connect to galaxy.ansible.com
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ 'test/test_runtime.py::test_load_plugins[modules]'
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+ # TODO
+ test/test_prerun.py::test_get_cache_dir_relative
+ )
+
+ epytest -o addopts=
+}