summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-11-16 13:14:12 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-11-16 13:14:33 -0600
commit8165ba0b55aae01ecb0a0cc8ec06bb0a42cd1cbd (patch)
tree082be917afac8e31d1a167a279806be8232de1ad
parentdev-python/prometheus-client: Enable pypy3 (diff)
downloadgentoo-8165ba0b55aae01ecb0a0cc8ec06bb0a42cd1cbd.tar.gz
gentoo-8165ba0b55aae01ecb0a0cc8ec06bb0a42cd1cbd.tar.bz2
gentoo-8165ba0b55aae01ecb0a0cc8ec06bb0a42cd1cbd.zip
www-apps/icingaweb2: add 2.12.1
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.12.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 71d91e8475e6..48883f3d17e5 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.11.4.tar.gz 11381515 BLAKE2B e524d04fd027377685826e1e3ff4a73efb040f8736d35fa496cf190a69dc2e6fedd82f678d5994d66a450efaff77764fd6a9504823ba17897506ff3d923566d8 SHA512 3012e75c35f3070a5dfcb356ed499f247651c99b7f39faf1917ade4568f5ba15a2820ff63cab2583748cdb7d158f86b7b87bf8f4c934d3bd6526929dd57e1eae
DIST icingaweb2-2.12.0.tar.gz 6354699 BLAKE2B a3d5af224a85278dbc244877fc8699617ff770a82e56f65c1e642eb23afd883b01d445d479319e9376b9a45e97d4ba028305c2773623b75464b19b1c00c12e72 SHA512 8e03c80ae0f4730307f606bcfed57978fea59d7917f2d505b063c29e05d913e047b6975bfc56673c0e71464a09578983d63a88c8efd35b1c80abb0d15384c275
+DIST icingaweb2-2.12.1.tar.gz 6353911 BLAKE2B c1f52444c2ccc1eeafce89603564f21269607bc183a3189b80d93ccba5d621bf8c8bd79c75e5c9aaeb6672870923f99c98c7ebc469147125a803d16b00f9426d SHA512 71e6ad8f947ee47ff0bd3924920584c558fbd8e371f76adb83cc08e95442e792009af79280c484afe478cf1a176cf2812c6be661d838f61f044abdc106ca0999
diff --git a/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild
new file mode 100644
index 000000000000..882211be2144
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.12.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:8.1[apache2?,cli,curl,fileinfo,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.2[apache2?,cli,curl,fileinfo,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ >=dev-libs/icinga-php-library-0.13.0
+ >=dev-libs/icinga-php-thirdparty-0.12.0
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+ fowners root:icingaweb2 "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}