summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-09-14 02:14:33 +0300
committerMichał Górny <mgorny@gentoo.org>2023-09-14 07:30:14 +0200
commit81036982d075644575bca6817a446d270c23d4e3 (patch)
treeebd5e72fd0a5f0029e8e05251da998de1583a1b2
parentnet-analyzer/wireshark: add support for verify-sig (diff)
downloadgentoo-81036982d075644575bca6817a446d270c23d4e3.tar.gz
gentoo-81036982d075644575bca6817a446d270c23d4e3.tar.bz2
gentoo-81036982d075644575bca6817a446d270c23d4e3.zip
dev-python/sqlglot: add 18.5.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32765 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-18.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index aa8f222b7b24..fa2d2a4f687b 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -5,3 +5,4 @@ DIST sqlglot-18.1.0.tar.gz 8570691 BLAKE2B 5c38baaa9600222c43f11338f2050eaf2e382
DIST sqlglot-18.2.0.tar.gz 8585675 BLAKE2B e66be52c97f18811e30d9ee2a3a8ae99ddb72e860a05f85fe48bb3e4b94c089fa425cf21ea66f2c6e45ac6f3823f339eb9fcfd1598a1c7a80d519790a6c0fc8a SHA512 3dffe0a7a6325829d648d988b4fe43cc27121a4d6684c863aee926c2100061309491cb1b5c6ad4076222b97131636cb843d705d7f4097aa600e177577e8ec7c4
DIST sqlglot-18.3.0.tar.gz 8599907 BLAKE2B 77e238dc8c8afe2c62a3c8c0ced6afbb0358a776189cef5e08b2c4830da04e573b11f703824a5038c5cf8d27cc31ac92f014aab459932742d8425ca834a6d473 SHA512 63ac8356483d13d6a53421f5fde8a4b2f56f34dc68d1d19a21e625c292a8ca9258da30905fd029dbe7bda59aebd0e358fa6e82cef240304ed1c571cfd19fc212
DIST sqlglot-18.4.1.tar.gz 8633851 BLAKE2B 0bae952b755f473a8cafd26df0c5e4a09c05bec228bb73bc99eca83eda12d05f1a68d8f07d659ed3418fce629d22ad5d7fd879f0b8feef39ac505a0c5bdbbf23 SHA512 405bb7efa2b5a5831e508818d6a0dab4d1aaf9cab69e98babfd4cc9fe321cbf9dff1d95aa879b736c497599156fb506edd871cd159c9bb94c60390c45d9eefa2
+DIST sqlglot-18.5.0.tar.gz 8634825 BLAKE2B aaf1854e87fea1ba598c45b12ef142bd825fcdfed4b247d4c0ee83e360154cb8a14ff3386e1635cd735f029b357d978dc3b39295cb1a733c653ade8efeabf0f7 SHA512 d75d45da61f0cc70a845776a4bb6aefc414b42cce81be3f8b26d305476e495f08cb017930af07bbe2296e049f65ea40137256b995233069ebfc076fce0bcab78
diff --git a/dev-python/sqlglot/sqlglot-18.5.0.ebuild b/dev-python/sqlglot/sqlglot-18.5.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}