summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-06-28 09:23:34 +0100
committerMarek Szuba <marecki@gentoo.org>2023-06-28 09:29:43 +0100
commit62f95c31cdb8d88663522dad41d574b79d91fc09 (patch)
treeb70fe68fe2bb76b3e3a22f3358373bb6f65c534c
parentprofiles/base: mask USE=system-protoc on dev-java/protobuf-java (diff)
downloadgentoo-62f95c31cdb8d88663522dad41d574b79d91fc09.tar.gz
gentoo-62f95c31cdb8d88663522dad41d574b79d91fc09.tar.bz2
gentoo-62f95c31cdb8d88663522dad41d574b79d91fc09.zip
dev-python/pyotherside: allow building against Qt6
Technically, USE=qt6 should still be masked on this package - but it seems the global "-qt6" for arch/amd64 overrides this. To be confirmed that this actually builds. Bug: https://bugs.gentoo.org/909274 Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pyotherside/pyotherside-1.6.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.6.0.ebuild b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
index 09ccc8660fa9..41263ea70ea1 100644
--- a/dev-python/pyotherside/pyotherside-1.6.0.ebuild
+++ b/dev-python/pyotherside/pyotherside-1.6.0.ebuild
@@ -20,8 +20,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
^^ ( qt5 qt6 )"
# qt6 TODO:
-# - add dev-qt/qt{gui,opengl}:6 once in the tree, test if qt6 deps okay then
-# - instrument qmake6 (no eqmake6 in the eclass yet)
+# - check if all qt6 deps are okay yet
# - multibuild for both qt5 and qt6 if requested
RDEPEND="
${PYTHON_DEPS}
@@ -33,7 +32,7 @@ RDEPEND="
dev-qt/qtsvg:5
)
qt6? (
- dev-qt/qtbase:6
+ dev-qt/qtbase:6[opengl]
dev-qt/qtdeclarative:6
dev-qt/qtsvg:6
)"
@@ -48,7 +47,7 @@ src_configure() {
if use qt5; then
eqmake5
elif use qt6; then
- die "Qt6 support is not ready yet"
+ eqmake6
else
# This should never happen if REQUIRED_USE is enforced
die "Neither Qt5 nor Qt6 support enabled, aborting"