summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-05-30 11:27:54 +0530
committerMichał Górny <mgorny@gentoo.org>2023-05-30 17:14:13 +0200
commit337727f10b6b7e6bf23caf0bb6bd89cf258686a6 (patch)
treefd364b7c28b432eef3c24e62ac0a9f2cb63f2a02
parentvirtual/dist-kernel: Bump to 5.10.181 (diff)
downloadgentoo-337727f10b6b7e6bf23caf0bb6bd89cf258686a6.tar.gz
gentoo-337727f10b6b7e6bf23caf0bb6bd89cf258686a6.tar.bz2
gentoo-337727f10b6b7e6bf23caf0bb6bd89cf258686a6.zip
sys-fs/vhba: update EAPI 7 -> 8 and porting to linux-mod-r1
Closes: https://bugs.gentoo.org/859553 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31224 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-fs/vhba/vhba-20211218-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-fs/vhba/vhba-20211218-r2.ebuild b/sys-fs/vhba/vhba-20211218-r2.ebuild
new file mode 100644
index 000000000000..62e5c2e3cf50
--- /dev/null
+++ b/sys-fs/vhba/vhba-20211218-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="https://cdemu.sourceforge.io/"
+SRC_URI="https://download.sourceforge.net/cdemu/vhba-module/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ virtual/udev
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+
+src_compile() {
+ local modlist=( vhba )
+ local modargs=( KDIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_prepare() {
+ default
+ # Avoid -Werror problems
+ sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ einfo "Generating udev rules ..."
+ udev_newrules - 69-vhba.rules <<-EOF
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}