summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-11-06 19:01:36 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-11-06 21:29:09 +0800
commit18027275e55fc2a39d3ca393dff7b3fe195a98df (patch)
treebe9f21fffff6914bccb4991b46e8d23e00fa662d
parentsys-kernel/vanilla-sources: Linux version bumps (diff)
downloadgentoo-18027275e55fc2a39d3ca393dff7b3fe195a98df.tar.gz
gentoo-18027275e55fc2a39d3ca393dff7b3fe195a98df.tar.bz2
gentoo-18027275e55fc2a39d3ca393dff7b3fe195a98df.zip
sci-libs/rocSPARSE: fix matrices dir for tests
Fix the following issue: Tests requiring data were skipped because of wrong directory. Bug: https://github.com/ROCmSoftwarePlatform/rocSPARSE/issues/227 Closes: https://github.com/gentoo/gentoo/pull/22806 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
index a196780e222e..7c554093db97 100644
--- a/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
+++ b/sci-libs/rocSPARSE/rocSPARSE-4.3.0-r1.ebuild
@@ -82,14 +82,14 @@ src_prepare() {
# Test need download data from https://sparse.tamu.edu (or other mirror site), check MD5, unpack and convert them into csr format
# This process is handled default by ${S}/cmake/ClientMatrices.cmake, but should be the responsibility of portage.
if use test; then
- mkdir -p "${BUILD_DIR}"/matrices
+ mkdir -p "${BUILD_DIR}"/clients/matrices
# compile and use the mtx2csr converter. Do not use any optimization flags, because it causes error!
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
- destination=${BUILD_DIR}/matrices/$(basename -s '.mtx' ${mtxfile}).csr
+ destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).csr
ebegin "Converting ${mtxfile} to ${destination}"
deps/convert ${mtxfile} ${destination}
eend $?