summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-28 11:23:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-28 11:46:57 +0200
commit061fbd457c24b204c3c8343bb32ed54a778b9b72 (patch)
tree84a5e62c273fc4e8d3ce4caecc7f0328c2690ed6
parentapp-crypt/mit-krb5: add 1.20 (diff)
downloadgentoo-061fbd457c24b204c3c8343bb32ed54a778b9b72.tar.gz
gentoo-061fbd457c24b204c3c8343bb32ed54a778b9b72.tar.bz2
gentoo-061fbd457c24b204c3c8343bb32ed54a778b9b72.zip
dev-python/gast: pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/gast/gast-0.5.3-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.3-r1.ebuild b/dev-python/gast/gast-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..d72434e33798
--- /dev/null
+++ b/dev-python/gast/gast-0.5.3-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest