summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-03 05:18:20 +0100
committerSam James <sam@gentoo.org>2022-10-03 05:18:20 +0100
commitfeb8ef855dec1c641c3d949ec11cc830c7e92e36 (patch)
treeb224552f915cc28d5356613334c85e522e5a5fc5 /sys-devel
parentsys-devel/binutils: sync 2.39-r2 from gx86 (diff)
downloadprefix-feb8ef855dec1c641c3d949ec11cc830c7e92e36.tar.gz
prefix-feb8ef855dec1c641c3d949ec11cc830c7e92e36.tar.bz2
prefix-feb8ef855dec1c641c3d949ec11cc830c7e92e36.zip
sys-devel/gcc-config: add 2.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/Manifest1
-rw-r--r--sys-devel/gcc-config/gcc-config-2.6.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 5045afbd82..92badc05ec 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1 +1,2 @@
DIST gcc-config-1.9.1.tar.xz 17628 BLAKE2B 8fce87038d9aed625d833327a7e335c311aeb04d44a07a7738def235333a9428664314ddd4da3a1d59d030136734377a838f25ff411b249aba25ea22a88460ee SHA512 6c518c266698277a1ad00a1624fc1ada15ed7096d05a520700c60a27180885169bd2051fb6869e6a958503c8eebc1cd6c211098501c5fe258ee11d96c6a0b069
+DIST gcc-config-2.6.tar.xz 17772 BLAKE2B 5f06ac46c64fd241be9e7b95e277395623f015016c5abbe5e3275dce3fbf326d998a897a915b87387c878a1b57cdc847a6f95fa0b7ca00aa954c13d00a6e7d09 SHA512 27de726b266b2f58f28a4eab0a77141a8c0cfc9e939f4f0ee8dd382578a1cdececd30a4ae15bab858fec01a533c41248c9858f25d5d7314c36e8f2fcd57df429
diff --git a/sys-devel/gcc-config/gcc-config-2.6.ebuild b/sys-devel/gcc-config/gcc-config-2.6.ebuild
new file mode 100644
index 0000000000..a1ecb1a2b2
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-2.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gcc-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+DESCRIPTION="Utility to manage compilers"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gcc-config.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+cc-wrappers +native-symlinks"
+
+RDEPEND=">=sys-apps/gentoo-functions-0.10"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8-copy-gcc-libs-darwin.patch
+ "${FILESDIR}"/${PN}-1.9-cygwin.patch
+)
+
+_emake() {
+ emake \
+ PV="${PVR}" \
+ SUBLIBDIR="$(get_libdir)" \
+ USE_CC_WRAPPERS="$(usex cc-wrappers)" \
+ USE_NATIVE_LINKS="$(usex native-symlinks)" \
+ TOOLCHAIN_PREFIX="${CHOST}-" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ # USE flag change can add or delete files in /usr/bin worth recaching
+ if [[ ! ${ROOT} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+ eselect compiler-shadow update all
+ fi
+
+ if ! has_version "sys-devel/gcc[gcj(-)]" && [[ -x "${EROOT}"/usr/bin/gcj ]] ; then
+ # Warn about obsolete /usr/bin/gcj for bug #804178
+ ewarn "Obsolete GCJ wrapper found: ${EROOT}/usr/bin/gcj!"
+ ewarn "Please delete this file unless you know it is needed (e.g. custom gcj install)."
+ ewarn "If you have no idea what this means, please delete the file:"
+ ewarn " rm ${EROOT}/usr/bin/gcj"
+ fi
+}