aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Englehorn <michael@englehorn.com>2019-06-19 15:54:56 +0000
committerPureTryOut <bribbers@disroot.org>2019-06-19 15:54:56 +0000
commit3dac6906216b203ab9fa9a29e682debdc8f6c818 (patch)
treeae66343b1f2b67e200ec0ec03835dea4014ac951
parentnet-im/riot-web: update to 1.2.2 (diff)
downloadmatrix-3dac6906216b203ab9fa9a29e682debdc8f6c818.tar.gz
matrix-3dac6906216b203ab9fa9a29e682debdc8f6c818.tar.bz2
matrix-3dac6906216b203ab9fa9a29e682debdc8f6c818.zip
net-im/riot-web: add emoji use flag and set it to be enabled by default
The `emoji` use flag causes net-im/riot-web to depend on media-fonts/noto-emoji. The riot-web developers no longer include emoji fonts in their package.
-rw-r--r--net-im/riot-web/riot-web-1.2.2-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-im/riot-web/riot-web-1.2.2-r1.ebuild b/net-im/riot-web/riot-web-1.2.2-r1.ebuild
new file mode 100644
index 0000000..64e1b4f
--- /dev/null
+++ b/net-im/riot-web/riot-web-1.2.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://riot.im"
+
+inherit eutils gnome2-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/vector-im/riot-web.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+DEPEND="sys-devel/binutils:*
+ net-libs/nodejs
+ sys-apps/yarn
+ x11-libs/libXScrnSaver
+ net-print/cups
+ dev-libs/nss
+ gnome-base/gconf
+ emoji? ( >=media-fonts/noto-emoji-20180823 )"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/Riot/libffmpeg.so
+ opt/Riot/libnode.so
+ opt/Riot/riot-web"
+
+DESTINATION="/" # We build and unpack a Debian installer, which already has everything in the proper directories {usr,opt}, so we just set the destination to "/"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == "9999" ]]; then
+ "${S}"/scripts/fetch-develop.deps.sh
+ fi
+
+ yarn install || die "Yarn module installation failed"
+
+ cp "${S}"/config.sample.json "${S}"/config.json
+}
+
+src_compile() {
+ yarn run build || die "Build failed"
+
+ "${S}"/node_modules/.bin/build --linux --x64 || die "Bundling failed"
+}
+
+src_install() {
+ ar x "${S}"/electron_app/dist/riot-web*.deb
+ tar xvf data.tar.xz
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF}
+ gunzip usr/share/doc/${PF}/changelog.gz
+ insinto ${DESTINATION}
+ doins -r usr
+ doins -r opt
+ fperms +x /opt/Riot/${PN}
+ dosym ${DESTINATION}/opt/Riot/${PN} ${DESTINATION}/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}