aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/systemd-swap/systemd-swap-4.0.1.ebuild')
-rw-r--r--sys-block/systemd-swap/systemd-swap-4.0.1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-block/systemd-swap/systemd-swap-4.0.1.ebuild b/sys-block/systemd-swap/systemd-swap-4.0.1.ebuild
index ce2d4b9b3..be4ee1494 100644
--- a/sys-block/systemd-swap/systemd-swap-4.0.1.ebuild
+++ b/sys-block/systemd-swap/systemd-swap-4.0.1.ebuild
@@ -2,24 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-info systemd
+
+inherit linux-info
DESCRIPTION="Script for creating swap space from zram swaps, swap files and swap partitions."
HOMEPAGE="https://github.com/Nefelim4ag/systemd-swap/"
-LICENSE="GPL-3"
-SLOT="0"
-
if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/Nefelim4ag/${PN}.git"
inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nefelim4ag/${PN}.git"
else
SRC_URI="https://github.com/Nefelim4ag/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
+LICENSE="GPL-3"
+SLOT="0"
+
CONFIG_CHECK="~ZRAM ~ZSWAP"
src_install() {
- emake PREFIX="${ED}/" install
+ default
+ keepdir /var/lib/systemd-swap
}