aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/snowflake/snowflake-2.5.1.ebuild')
-rw-r--r--net-proxy/snowflake/snowflake-2.5.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-proxy/snowflake/snowflake-2.5.1.ebuild b/net-proxy/snowflake/snowflake-2.5.1.ebuild
new file mode 100644
index 000000000..fa82ac8eb
--- /dev/null
+++ b/net-proxy/snowflake/snowflake-2.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+JOB_ID="222736"
+DESCRIPTION="Pluggable Transport using WebRTC, inspired by Flashproxy"
+HOMEPAGE="
+ https://snowflake.torproject.org/
+ https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/snowflake
+"
+SRC_URI="https://gitlab.torproject.org/tpo/anti-censorship/pluggable-transports/${PN}/-/jobs/${JOB_ID}/artifacts/raw/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMPONENTS=( broker client probetest proxy server )
+
+src_compile() {
+ for component in "${COMPONENTS[@]}"; do
+ pushd ${component} || die
+ einfo "Building ${component}"
+ ego build
+ popd || die
+ done
+}
+
+src_test() {
+ ego test ./...
+}
+
+src_install() {
+ local component
+ for component in "${COMPONENTS[@]}"; do
+ newbin ${component}/${component} snowflake-${component}
+ newdoc ${component}/README.md README_${component}.md
+ done
+
+ systemd_dounit "${FILESDIR}"/snowflake-proxy.service
+ newinitd "${FILESDIR}"/snowflake-proxy.initd snowflake-proxy
+
+ einstalldocs
+ dodoc doc/*.txt doc/*.md
+ doman doc/*.1
+}