aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/rum/rum-1.3.6.ebuild')
-rw-r--r--dev-db/rum/rum-1.3.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/rum/rum-1.3.6.ebuild b/dev-db/rum/rum-1.3.6.ebuild
new file mode 100644
index 000000000..fe4cc3e29
--- /dev/null
+++ b/dev-db/rum/rum-1.3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 10 11 12 )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="RUM access method - inverted index with additional information in posting lists"
+HOMEPAGE="https://github.com/postgrespro/rum"
+SRC_URI="https://github.com/postgrespro/rum/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+USE_PGXS=1
+
+src_compile() {
+ postgres-multi_foreach emake USE_PGXS=1
+}
+
+src_test() {
+ postgres-multi_foreach emake USE_PGXS=1 installcheck
+}
+
+src_install() {
+ postgres-multi_foreach emake USE_PGXS=1 DESTDIR="${D}" install
+}