aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-rpg/snoot-game/Manifest1
-rw-r--r--games-rpg/snoot-game/metadata.xml18
-rw-r--r--games-rpg/snoot-game/snoot-game-1.7.ebuild38
3 files changed, 57 insertions, 0 deletions
diff --git a/games-rpg/snoot-game/Manifest b/games-rpg/snoot-game/Manifest
new file mode 100644
index 000000000..54a282092
--- /dev/null
+++ b/games-rpg/snoot-game/Manifest
@@ -0,0 +1 @@
+DIST SnootGame-Update7_Fangsgiving-linux.tar.bz2 357494376 BLAKE2B 13d1603d2b8d2936b76b1289dddc507617bb574bab938ae6b00ca1ce0d9ba3fd32f87fc649eedbb4fe1c3c73e81632faa16bb02aae5175ae3c3a32843236aa0f SHA512 58f70e59fa906bcfbfe52a13d4db22bad589f1ad55e8ebc11db420fee3be208bcd67e38caf6b58092a9e0d85e8d37a6aa2359f879091b8679d8523fc2b31e2bf
diff --git a/games-rpg/snoot-game/metadata.xml b/games-rpg/snoot-game/metadata.xml
new file mode 100644
index 000000000..6654dbec9
--- /dev/null
+++ b/games-rpg/snoot-game/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Seth Price</name>
+ <email>sprice623@aol.com</email>
+ </maintainer>
+ <longdescription lang="en">
+ You play as Anon, a lonely, faceless, nobody, reject who finds himself
+ in the dinosaur themed acid trip of a school named Volcano High.
+ Here Anon meets the qt ptero known as Fang and their clown-vomit colored
+ posse of reject friends and other associated thorns-in-the-side.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://git.snootgame.xyz/Cavemanon/SnootGame/issues</bugs-to>
+ <changelog>https://snootgame.xyz/Patch7-changelog.html</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/games-rpg/snoot-game/snoot-game-1.7.ebuild b/games-rpg/snoot-game/snoot-game-1.7.ebuild
new file mode 100644
index 000000000..ec4305f70
--- /dev/null
+++ b/games-rpg/snoot-game/snoot-game-1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+inherit python-single-r1 desktop wrapper
+
+DESCRIPTION="Visual novel parody of Goodbye Volcano High"
+MY_PV="Update7_Fangsgiving"
+HOMEPAGE="https://snootgame.xyz/"
+SRC_URI="https://secureupdates.snootgame.xyz/SnootGame-${MY_PV}-linux.tar.bz2"
+
+LICENSE="AGPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/SnootGame-${MY_PV}-linux/"
+
+src_install() {
+ local dir=/opt/${PN}
+ insinto "${dir}"
+
+ doins -r "${S}/."
+ dodoc README.md
+
+ fperms +x ${dir}/lib/linux-i686/SnootGame
+ fperms +x ${dir}/lib/linux-x86_64/SnootGame
+ fperms +x ${dir}/SnootGame.sh
+
+ make_wrapper ${PN} "./SnootGame.sh" "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Snoot Game"
+
+}