aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-05-14 04:48:54 -0400
committerJoe Kappus <joe@wt.gd>2024-05-14 04:50:37 -0400
commit795b8fd5bed35989ef2520b35d735b72f71ba7d4 (patch)
tree449082614299a1b0ab474e02e35dfcd8437d09cd /sys-power
parentsys-power/linux-tools-power-x86: drop 5.18 (diff)
downloadguru-795b8fd5bed35989ef2520b35d735b72f71ba7d4.tar.gz
guru-795b8fd5bed35989ef2520b35d735b72f71ba7d4.tar.bz2
guru-795b8fd5bed35989ef2520b35d735b72f71ba7d4.zip
sys-power/linux-tools-power-x86: add 6.6, fix cflags
Closes: https://bugs.gentoo.org/901453 Closes: https://bugs.gentoo.org/931485 Signed-off-by: Joe Kappus <joe@wt.gd>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/linux-tools-power-x86/Manifest1
-rw-r--r--sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch (renamed from sys-power/linux-tools-power-x86/files/linux-tools-power-x86-5.18-cflags.patch)18
-rw-r--r--sys-power/linux-tools-power-x86/linux-tools-power-x86-6.1.ebuild2
-rw-r--r--sys-power/linux-tools-power-x86/linux-tools-power-x86-6.6.ebuild92
4 files changed, 106 insertions, 7 deletions
diff --git a/sys-power/linux-tools-power-x86/Manifest b/sys-power/linux-tools-power-x86/Manifest
index ef5ea75ef..f47107e8b 100644
--- a/sys-power/linux-tools-power-x86/Manifest
+++ b/sys-power/linux-tools-power-x86/Manifest
@@ -1 +1,2 @@
DIST linux-6.1.tar.xz 134728520 BLAKE2B ae60257860b2bd1bd708d183f0443afc60ebbd2b3d535c45e44c2e541bd0928530a3b62de6385dd4e4726ebbedcc0a871d4f3ffb4105b9f1f6d8ed7467f5688e SHA512 6ed2a73c2699d0810e54753715635736fc370288ad5ce95c594f2379959b0e418665cd71bc512a0273fe226fe90074d8b10d14c209080a6466498417a4fdda68
+DIST linux-6.6.tar.xz 140064536 BLAKE2B 5f02fd8696d42f7ec8c5fbadec8e7270bdcfcb1f9844a6c4db3e1fd461c93ce1ccda650ca72dceb4890ebcbbf768ba8fba0bce91efc49fbd2c307b04e95665f2 SHA512 458b2c34d46206f9b4ccbac54cc57aeca1eaecaf831bc441e59701bac6eadffc17f6ce24af6eadd0454964e843186539ac0d63295ad2cc32d112b60360c39a35
diff --git a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-5.18-cflags.patch b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch
index 700baa781..111fb1a88 100644
--- a/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-5.18-cflags.patch
+++ b/sys-power/linux-tools-power-x86/files/linux-tools-power-x86-6.6-cflags.patch
@@ -1,28 +1,34 @@
+diff --git a/tools/power/x86/intel-speed-select/Makefile b/tools/power/x86/intel-speed-select/Makefile
+index 7221f2f55e8b..96b5a456a4c5 100644
--- a/tools/power/x86/intel-speed-select/Makefile
+++ b/tools/power/x86/intel-speed-select/Makefile
-@@ -13,7 +13,7 @@
+@@ -13,7 +13,7 @@ endif
# Do not use make's built-in rules
# (this improves performance and avoids hard-to-debug behaviour);
MAKEFLAGS += -r
-override CFLAGS += -O2 -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
-+override CFLAGS += -Wall -g -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
++override CFLAGS += -Wall -D_GNU_SOURCE -I$(OUTPUT)include -I/usr/include/libnl3
override LDFLAGS += -lnl-genl-3 -lnl-3
ALL_TARGETS := intel-speed-select
+diff --git a/tools/power/x86/turbostat/Makefile b/tools/power/x86/turbostat/Makefile
+index 92e139b9c792..972fb3c5a514 100644
--- a/tools/power/x86/turbostat/Makefile
+++ b/tools/power/x86/turbostat/Makefile
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,7 @@ ifeq ("$(origin O)", "command line")
endif
turbostat : turbostat.c
--override CFLAGS += -O2 -Wall -I../../../include
-+override CFLAGS += -Wall -I../../../include
+-override CFLAGS += -O2 -Wall -Wextra -I../../../include
++override CFLAGS += -Wall -Wextra -I../../../include
override CFLAGS += -DMSRHEADER='"../../../../arch/x86/include/asm/msr-index.h"'
override CFLAGS += -DINTEL_FAMILY_HEADER='"../../../../arch/x86/include/asm/intel-family.h"'
override CFLAGS += -D_FILE_OFFSET_BITS=64
+diff --git a/tools/power/x86/x86_energy_perf_policy/Makefile b/tools/power/x86/x86_energy_perf_policy/Makefile
+index 666b325a62a2..0053893229fb 100644
--- a/tools/power/x86/x86_energy_perf_policy/Makefile
+++ b/tools/power/x86/x86_energy_perf_policy/Makefile
-@@ -9,7 +9,7 @@
+@@ -9,7 +9,7 @@ ifeq ("$(origin O)", "command line")
endif
x86_energy_perf_policy : x86_energy_perf_policy.c
diff --git a/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.1.ebuild b/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.1.ebuild
index a2c0295b1..d46d085b6 100644
--- a/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.1.ebuild
+++ b/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit fcaps linux-info python-r1 toolchain-funcs
diff --git a/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.6.ebuild b/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.6.ebuild
new file mode 100644
index 000000000..d46d085b6
--- /dev/null
+++ b/sys-power/linux-tools-power-x86/linux-tools-power-x86-6.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 2013-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit fcaps linux-info python-r1 toolchain-funcs
+
+DESCRIPTION="Linux x86 CPU power tools"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://cdn.kernel.org/pub/linux/kernel/v${PV%%.*}.x/linux-${PV}.tar.xz"
+S="${WORKDIR}/linux-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64"
+IUSE="pstate-tracer"
+
+CDEPEND="dev-libs/libnl:3"
+RDEPEND="
+ pstate-tracer? (
+ ${PYTHON_DEPS}
+ dev-python/gnuplot-py[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-visualization/gnuplot
+ )
+"
+DEPEND="
+ ${CDEPEND}
+ virtual/os-headers
+"
+
+REQUIRED_USE="pstate-tracer? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )
+FILECAPS=( 'cap_sys_rawio=ep' usr/bin/turbostat )
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK_MODULES="CONFIG_X86_MSR" || ewarn "msr module is needed at runtime"
+ fi
+}
+
+src_configure() {
+ export bindir="${EPREFIX}/usr/bin"
+ export sbindir="${EPREFIX}/usr/sbin"
+ export mandir="${EPREFIX}/usr/share/man"
+ export includedir="${EPREFIX}/usr/include"
+ export libdir="${EPREFIX}/usr/$(get_libdir)"
+ export localedir="${EPREFIX}/usr/share/locale"
+ export docdir="${EPREFIX}/usr/share/doc/${PF}"
+ export confdir="${EPREFIX}/etc"
+ export bash_completion_dir="${EPREFIX}/usr/share/bash-completion/completions"
+ export V=1
+}
+
+src_compile() {
+ myemakeargs=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ VERSION=${PV}
+ )
+ emake -C tools/power/x86/intel-speed-select "${myemakeargs[@]}"
+ emake -C tools/power/x86/turbostat "${myemakeargs[@]}"
+ emake -C tools/power/x86/x86_energy_perf_policy "${myemakeargs[@]}"
+}
+
+src_install() {
+ pushd "${S}/tools/power/x86/intel-speed-select" || die
+ emake "${myemakeargs[@]}" DESTDIR="${D}" install
+ popd || die
+ pushd "${S}/tools/power/x86/turbostat" || die
+ emake "${myemakeargs[@]}" DESTDIR="${D}" install
+ popd || die
+ pushd "${S}/tools/power/x86/x86_energy_perf_policy" || die
+ emake "${myemakeargs[@]}" DESTDIR="${D}" install
+ popd || die
+
+ if use pstate-tracer; then
+ python_foreach_impl python_doscript tools/power/x86/intel_pstate_tracer/intel_pstate_tracer.py
+ python_foreach_impl python_doscript tools/power/x86/amd_pstate_tracer/amd_pstate_trace.py
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+}