aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTakuya Wakazono <pastalian46@gmail.com>2024-11-09 20:41:28 +0900
committerTakuya Wakazono <pastalian46@gmail.com>2024-11-09 20:44:15 +0900
commitc1fb66b1046daec042cd189cef23fcf4bc5ad88d (patch)
treee50d0e7923b7a76f43627caeefdfc1336410f38d /sys-auth
parentapp-misc/lf: use ego instead of calling go directly (diff)
downloadguru-c1fb66b1046daec042cd189cef23fcf4bc5ad88d.tar.gz
guru-c1fb66b1046daec042cd189cef23fcf4bc5ad88d.tar.bz2
guru-c1fb66b1046daec042cd189cef23fcf4bc5ad88d.zip
sys-auth/pam-gnupg: fix installation path
The correct path for pam module should be obtained using getpam_mod_dir. Closes: https://bugs.gentoo.org/943121 Signed-off-by: Takuya Wakazono <pastalian46@gmail.com>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam-gnupg/pam-gnupg-0.4-r1.ebuild (renamed from sys-auth/pam-gnupg/pam-gnupg-0.4.ebuild)18
1 files changed, 8 insertions, 10 deletions
diff --git a/sys-auth/pam-gnupg/pam-gnupg-0.4.ebuild b/sys-auth/pam-gnupg/pam-gnupg-0.4-r1.ebuild
index 39dba08aa..b5970c5c7 100644
--- a/sys-auth/pam-gnupg/pam-gnupg-0.4.ebuild
+++ b/sys-auth/pam-gnupg/pam-gnupg-0.4-r1.ebuild
@@ -1,20 +1,23 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools pam
DESCRIPTION="Unlock GnuPG keys on login"
HOMEPAGE="https://github.com/cruegge/pam-gnupg"
SRC_URI="https://github.com/cruegge/pam-gnupg/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
RDEPEND="
->=sys-libs/pam-1.6.1
->=app-crypt/gnupg-2.4.5-r1
+ >=sys-libs/pam-1.6.1
+ >=app-crypt/gnupg-2.4.5-r1
"
+DEPEND="${RDEPEND}"
src_prepare() {
default
@@ -22,10 +25,5 @@ src_prepare() {
}
src_configure() {
- econf \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --with-moduledir=/usr/lib64/security \
- --mandir=/usr/share/man || die
+ econf --with-moduledir="$(getpam_mod_dir)"
}