aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-01 01:12:26 +0200
committerIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-01 01:31:33 +0200
commit45a98f9f8d75c2920491a12c3b4b07c6aad9a0be (patch)
tree817239c4e572f8e88dec5be82caf90b5e9368d9f /sci-physics
parentsci-physics/openmodelica: Ensure graceful abort in case of any system command... (diff)
downloadguru-45a98f9f8d75c2920491a12c3b4b07c6aad9a0be.tar.gz
guru-45a98f9f8d75c2920491a12c3b4b07c6aad9a0be.tar.bz2
guru-45a98f9f8d75c2920491a12c3b4b07c6aad9a0be.zip
sci-physics/openmodelica: Code cleanup with pushd/popd
Signed-off-by: Ivan Lloro <ivan.lloro.boada@gmail.com>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/openmodelica/openmodelica-1.23.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
index a4bbc0e6b3..e533cf9907 100644
--- a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
+++ b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
@@ -132,8 +132,7 @@ src_compile() {
# [2024-07-15]
# OMSens is disabled in "${WORKDIR}/${P}/CMakeLists.txt" (## omc_add_subdirectory(OMSens)) due to lack of a
# working "${WORKDIR}/${P}/OMSens/CMakeLists.txt". So, we compile it manually.
- PWD=$(pwd)
- cd "${WORKDIR}"/"${P}"/OMSens/fortran_interface
+ pushd OMSens/fortran_interface > /dev/null || die
gfortran -fPIC -c Rutf.for Rut.for Curvif.for || die
# BUG: Undefined symbol curvif_ in
# ${WORKDIR}/${P}/OMSens/fortran_interface/curvif_simplified.cpython-312-x86_64-linux-gnu.so
@@ -141,7 +140,7 @@ src_compile() {
# ${WORKDIR}/${P}/OMSens/fortran_interface/curvif_simplified.cpython-312-x86_64-linux-gnu.so
# This bug causes "Vectorial Parameter Based Sensitivity Analysis" in OMSens to fail.
f2py --verbose -c -I. Curvif.o Rutf.o Rut.o -m curvif_simplified curvif_simplified.pyf Curvif_simplified.f90 || die
- cd "${PWD}"
+ popd || die
cmake_src_compile
}