aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-04 23:16:35 +0200
committerIvan Lloro <ivan.lloro.boada@gmail.com>2024-08-04 23:27:13 +0200
commit0d0da46122a69c1ff7541124dfc570234be64bd1 (patch)
tree380ae41d7312cbb151334f953917641b6ef83e8e /sci-physics
parentsys-fs/sanoid: add local USE flags (diff)
downloadguru-0d0da46122a69c1ff7541124dfc570234be64bd1.tar.gz
guru-0d0da46122a69c1ff7541124dfc570234be64bd1.tar.bz2
guru-0d0da46122a69c1ff7541124dfc570234be64bd1.zip
sci-physics/openmodelica: Add missing include statement to fix compilation issue with GCC 14
Signed-off-by: Ivan Lloro <ivan.lloro.boada@gmail.com>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/openmodelica/files/openmodelica-1.23.1-include_algorithm.patch14
-rw-r--r--sci-physics/openmodelica/openmodelica-1.23.1.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/sci-physics/openmodelica/files/openmodelica-1.23.1-include_algorithm.patch b/sci-physics/openmodelica/files/openmodelica-1.23.1-include_algorithm.patch
new file mode 100644
index 0000000000..404637e7ea
--- /dev/null
+++ b/sci-physics/openmodelica/files/openmodelica-1.23.1-include_algorithm.patch
@@ -0,0 +1,14 @@
+add <algorithm> to define std::unique and std::find
+Fixes compilation error with GCC 14
+
+See https://github.com/OpenModelica/OMSimulator/pull/1295
+--- a/OMSimulator/src/OMSimulatorLib/Model.cpp
++++ b/OMSimulator/src/OMSimulatorLib/Model.cpp
+@@ -43,6 +43,7 @@
+
+ #include "minizip.h"
+ #include <thread>
++#include <algorithm>
+
+ oms::Model::Model(const oms::ComRef& cref, const std::string& tempDir)
+ : cref(cref), tempDir(tempDir), resultFilename(std::string(cref) + "_res.mat")
diff --git a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
index 619aeb6eab..1a24909304 100644
--- a/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
+++ b/sci-physics/openmodelica/openmodelica-1.23.1.ebuild
@@ -85,6 +85,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/"${P}"-raw_strings.patch
+ "${FILESDIR}"/"${P}"-include_algorithm.patch
)
src_unpack() {