aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2021-12-29 14:06:15 +0200
committerViorel Munteanu <ceamac.paragon@gmail.com>2021-12-29 14:07:23 +0200
commitca306a9311879bbe98993d66dfb98bd7fc36c679 (patch)
tree25104a13be8d2e490099baf220ad3b323261a2e1 /net-misc
parentnet-misc/maestral-qt: fix deps (diff)
downloadguru-ca306a9311879bbe98993d66dfb98bd7fc36c679.tar.gz
guru-ca306a9311879bbe98993d66dfb98bd7fc36c679.tar.bz2
guru-ca306a9311879bbe98993d66dfb98bd7fc36c679.zip
net-misc/maestral: fix deps and tests
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/maestral/maestral-1.5.2.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-misc/maestral/maestral-1.5.2.ebuild b/net-misc/maestral/maestral-1.5.2.ebuild
index 6ce8dbcf6..54d55b1bd 100644
--- a/net-misc/maestral/maestral-1.5.2.ebuild
+++ b/net-misc/maestral/maestral-1.5.2.ebuild
@@ -29,22 +29,29 @@ DEPEND="
>=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
>=dev-python/requests-2.6.2[${PYTHON_USEDEP}]
>=dev-python/sdnotify-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/setuptools-41.0.0[${PYTHON_USEDEP}]
>=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
<dev-python/survey-4.0.0[${PYTHON_USEDEP}]
>=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
- python_targets_python3_8? ( dev-python/importlib_metadata[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_8)
"
RDEPEND="${DEPEND}"
BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest-benchmark[${PYTHON_USEDEP}] )
"
-# Skipped: Requires auth token
-RESTRICT=test
+distutils_enable_tests pytest
-distutils_enable_tests setup.py
+python_prepare_all()
+{
+ # this test requires systemd
+ sed -i -e 's/test_autostart/_&/' tests/offline/test_cli.py || die
+
+ # this test requires network
+ sed -i -e 's/test_check_for_updates/_&/' tests/offline/test_main.py || die
+
+ distutils-r1_python_prepare_all
+}
pkg_postinst()
{