aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-03-28 09:10:06 -0400
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-03-28 09:10:15 -0400
commita7fb9bb3b7957ab7d994990aca67725e8b7f1145 (patch)
tree063eb1bfb4ea776cbb176e76c05ddf4aa8614d70 /net-mail
parentx11-themes/catppuccin-cursors: new package, add 0.2.0 (diff)
downloadguru-a7fb9bb3b7957ab7d994990aca67725e8b7f1145.tar.gz
guru-a7fb9bb3b7957ab7d994990aca67725e8b7f1145.tar.bz2
guru-a7fb9bb3b7957ab7d994990aca67725e8b7f1145.zip
net-mail/dovecot-fts-xapian: add 1.7.9
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.9.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 04dba3d1f..6d3a2d0c7 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -2,3 +2,4 @@ DIST dovecot-fts-xapian-1.5.5.tar.gz 33228 BLAKE2B b8e86b3655a6b7291961cfbd39d6e
DIST dovecot-fts-xapian-1.5.7.tar.gz 33594 BLAKE2B 5d83cf5292ecf7d7245a56d21587302ea8c3bc5b0374c5c77013059fa66e4d187bb26b9c1d928e8ad324d235a79bd97a6878086fc19b493b1aeae1a312bceaf1 SHA512 eb3b7e19ba522dd9e9c2952c3022b15249889c814e8a90b50836526ab5000b26e0e835b71d3a4439f03d5399277b70a3ffeb366ca42061b647ab8ce251268c3b
DIST dovecot-fts-xapian-1.5.9.tar.gz 34220 BLAKE2B 8cf0772122d5dd8cf25fa2e8a5c02c8a315fdf4fbd346db3d01e78aa3e1116d42fbf30c155a364e064bd2ea4e9b67a48a69b3a3dada2c471c550f1d4fabbc8bd SHA512 e5961e5f6aeed6efabf456487307dfd09e255077e8c2c3af6c390b73b48dd2613f09ad4dfcd64974a91463a05a55078edfb7368d8c01ce0a839847823507b91f
DIST dovecot-fts-xapian-1.7.6.tar.gz 36626 BLAKE2B 4112204e78fce042a4db5e6d3bd5d12e2ca6be8199ded4f7b3b7e0ff9977268491aa7e524f00103e1ee07d5ce0b59dcea171c5be19c7857dbeae9416c4fe984e SHA512 83b25bae097fceb56b62355cd8e10788bea850c2f312eb15fca72fb9c1d033d54e56c251eb27eeb971fe405da9d6a3509a3a700bbd0602d785949548ac15ba1f
+DIST dovecot-fts-xapian-1.7.9.tar.gz 36884 BLAKE2B 6e2520a7b8a8250caa2a92af15e6eecdfbdbb542ff439e91baa0c084b3a6f6b02918decd0e0f0d888aba4db54b9566d63a796385a4d56970b69035845e20f84a SHA512 9df23186648902c9ca38f861496bff3e00005096be960a138b7d20eb3baff2734e16949614d1207cce34f2d6626634f58b35ea2c0500e2981f05eea1ad9da718
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.9.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.9.ebuild
new file mode 100644
index 000000000..9e8a22927
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.7.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fts-xapian-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ ${FILESDIR}/bug-887887_allow-O2-override.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Disable hardening so CFLAGS are left up to the Gentoo user
+ # https://bugs.gentoo.org/888751
+ econf \
+ --enable-hardening=no \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}