aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiFei Zhu <zhuyifei1999@gmail.com>2023-12-28 20:46:11 -0800
committerYiFei Zhu <zhuyifei1999@gmail.com>2023-12-28 20:46:11 -0800
commit17459d22ae169dca5639fea5f33a9f7d4ab99412 (patch)
treeb1be4e23f97e99b385c971f2d2fc075303f7ae66 /net-analyzer
parentdev-libs/libcli: Remove -Werror (diff)
downloadguru-17459d22ae169dca5639fea5f33a9f7d4ab99412.tar.gz
guru-17459d22ae169dca5639fea5f33a9f7d4ab99412.tar.bz2
guru-17459d22ae169dca5639fea5f33a9f7d4ab99412.zip
net-analyzer/netsniff-ng: Respect CFLAGS, cleanup emake command
Closes: https://bugs.gentoo.org/920892 Closes: https://bugs.gentoo.org/920893 Signed-off-by: YiFei Zhu <zhuyifei1999@gmail.com>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netsniff-ng/netsniff-ng-0.6.8-r1.ebuild (renamed from net-analyzer/netsniff-ng/netsniff-ng-0.6.8.ebuild)17
1 files changed, 5 insertions, 12 deletions
diff --git a/net-analyzer/netsniff-ng/netsniff-ng-0.6.8.ebuild b/net-analyzer/netsniff-ng/netsniff-ng-0.6.8-r1.ebuild
index a013c30f4..077fe3940 100644
--- a/net-analyzer/netsniff-ng/netsniff-ng-0.6.8.ebuild
+++ b/net-analyzer/netsniff-ng/netsniff-ng-0.6.8-r1.ebuild
@@ -32,7 +32,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- sys-devel/flex
+ app-alternatives/lex
sys-devel/bison
dev-libs/libsodium
virtual/pkgconfig
@@ -41,14 +41,9 @@ BDEPEND="
src_prepare() {
default
- sed -e '/CFLAGS/s:?=:+=:' \
- -e '/CPPFLAGS/s:?=:+=:' \
- -e '/CFLAGS/s:\(-g\|-O2\|-O3\|-m\(arch\|tune\)=native\)::g' \
- -i Makefile || die
-
- if ! grep -Fq nacl-20110221 curvetun/nacl_build.sh ; then
- die "have nacl-20110221, expected $(grep ${MY_NACL_P} curvetun/nacl_build.sh)"
- fi
+ # force mausezahn to respect CFLAGS
+ sed -e '/CFLAGS/s:=:+=:' -i Extra || die
+ sed -e 's/ -O2//' -i mausezahn/Makefile || die
export NACL_INC_DIR="${EPREFIX}/usr/include/nacl"
export NACL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)/nacl"
@@ -77,9 +72,7 @@ src_configure() {
}
src_compile() {
- emake CC="$(tc-getCC)" LD="$(tc-getCC)" CCACHE="" \
- LEX=lex YAAC=bison STRIP=true \
- Q= HARDENING=1
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" CCACHE="" Q=
}
src_install() {