aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernandez Hernandez <leohdz172@outlook.com>2022-02-11 20:29:08 -0600
committerLeonardo Hernandez Hernandez <leohdz172@outlook.com>2022-02-11 20:30:27 -0600
commit29315cdffe24196da0de3f6a43cf1009d64cba62 (patch)
tree0271b22bfc86d2498ff4da3e303ba31b3c881fb6 /gui-apps
parentwww-apps/code-server-bin: fix licenses (diff)
downloadguru-29315cdffe24196da0de3f6a43cf1009d64cba62.tar.gz
guru-29315cdffe24196da0de3f6a43cf1009d64cba62.tar.bz2
guru-29315cdffe24196da0de3f6a43cf1009d64cba62.zip
gui-apps/fnott: new package
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Leonardo Hernandez Hernandez <leohdz172@outlook.com>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/fnott/Manifest1
-rw-r--r--gui-apps/fnott/fnott-1.2.0.ebuild43
-rw-r--r--gui-apps/fnott/metadata.xml8
3 files changed, 52 insertions, 0 deletions
diff --git a/gui-apps/fnott/Manifest b/gui-apps/fnott/Manifest
new file mode 100644
index 000000000..b4c1b3782
--- /dev/null
+++ b/gui-apps/fnott/Manifest
@@ -0,0 +1 @@
+DIST fnott-1.2.0.tar.gz 377321 BLAKE2B 5b12edb81f7043eb6b7c69c8b20c595a3a86b94ff1e5aac2ce8aa43d696d92b08014cbf3b730a4851350cf8aaf442109971f532ce31f6b7cff616b1d1848ddc7 SHA512 a5eb006e2043f22b1790bb3a20d1b3dcef7ddfa4d6c2881fd05c7aa52f1de49f4ca30867ffb90a72f77ded9107945d7cb1ea88aa497fec6a53799e78a877c863
diff --git a/gui-apps/fnott/fnott-1.2.0.ebuild b/gui-apps/fnott/fnott-1.2.0.ebuild
new file mode 100644
index 000000000..19ed939ac
--- /dev/null
+++ b/gui-apps/fnott/fnott-1.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EMESON_BUILDTYPE="release"
+
+inherit meson
+
+DESCRIPTION="Keyboard driven and lightweight Wayland notification daemon."
+HOMEPAGE="https://codeberg.org/dnkl/fnott"
+SRC_URI="https://codeberg.org/dnkl/fnott/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}"
+
+DEPEND="
+ x11-libs/pixman
+ media-libs/libpng
+ dev-libs/wayland
+ sys-apps/dbus
+ media-libs/fcft
+ media-libs/freetype
+ media-libs/fontconfig
+ dev-libs/wayland-protocols
+"
+RDEPEND="${DEPEND}
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ app-text/scdoc
+ dev-libs/tllist
+"
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/"${PN}" || die
+}
diff --git a/gui-apps/fnott/metadata.xml b/gui-apps/fnott/metadata.xml
new file mode 100644
index 000000000..8d7e2e9ba
--- /dev/null
+++ b/gui-apps/fnott/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>leohdz172@outlook.com</email>
+ <name>Leonardo Hernandez Hernandez</name>
+ </maintainer>
+</pkgmetadata>