aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMattia Gasparotto <gasmat04@gmail.com>2021-11-11 17:16:13 +0100
committerMattia Gasparotto <gasmat04@gmail.com>2021-11-11 17:16:13 +0100
commit1c856af2a184f4c96360ea7837e326eee9a39c8d (patch)
tree2ebd0a72878dd5cdcceb963c112c73c21b9d4071 /gui-apps
parentnet-voip/gnome-calls: Version Bump (diff)
downloadguru-1c856af2a184f4c96360ea7837e326eee9a39c8d.tar.gz
guru-1c856af2a184f4c96360ea7837e326eee9a39c8d.tar.bz2
guru-1c856af2a184f4c96360ea7837e326eee9a39c8d.zip
gui-apps/wlogout: added new package
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Mattia Gasparotto <gasmat04@gmail.com>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wlogout/Manifest1
-rw-r--r--gui-apps/wlogout/metadata.xml18
-rw-r--r--gui-apps/wlogout/wlogout-1.1.1.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/gui-apps/wlogout/Manifest b/gui-apps/wlogout/Manifest
new file mode 100644
index 000000000..de8c70b9d
--- /dev/null
+++ b/gui-apps/wlogout/Manifest
@@ -0,0 +1 @@
+DIST 1.1.1.tar.gz 540189 BLAKE2B 44831029c85403f3e9eddca38f6936a1c627c6c78c596d0e5fa867133827ff85f10063fbc9324e9f9b42a1951247cf89d98133b82028d223e33ae1ad76b55c40 SHA512 bca5de1c7168a11d418d206276d8715ef0f64e020985872062974f726fd969f78bd631a94d1076039aec20e2e72b4b6de5095da79f58919bfbf7ff2e2fd93ec5
diff --git a/gui-apps/wlogout/metadata.xml b/gui-apps/wlogout/metadata.xml
new file mode 100644
index 000000000..70b26438b
--- /dev/null
+++ b/gui-apps/wlogout/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gasmat04@gmail.com</email>
+ <name>Mattia Gasparotto</name>
+ </maintainer>
+ <use>
+ <flag name="layershell">Enable transparency</flag>
+ <flag name="doc">Install man pages</flag>
+ <flag name="bash-completions">Enable completions for bash shell</flag>
+ <flag name="fish-completions">Enable completions for fish shell</flag>
+ <flag name="zsh-completions">Enable completions for zsh shell</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ArtsyMacaw/wlogout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/wlogout/wlogout-1.1.1.ebuild b/gui-apps/wlogout/wlogout-1.1.1.ebuild
new file mode 100644
index 000000000..aa0765bac
--- /dev/null
+++ b/gui-apps/wlogout/wlogout-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A wayland based logout menu"
+HOMEPAGE="https://github.com/ArtsyMacaw/wlogout"
+SRC_URI="https://github.com/ArtsyMacaw/${PN}/archive/refs/tags/${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="layershell doc bash-completions fish-completions zsh-completions"
+
+DEPEND="x11-libs/gtk+:=
+ dev-libs/gobject-introspection
+ doc? ( app-text/scdoc )
+ layershell? ( gui-libs/gtk-layer-shell )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc man-pages)
+ $(meson_use bash-completions)
+ $(meson_use fish-completions)
+ $(meson_use zsh-completions)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+}