aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-12 05:52:11 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-12 05:56:51 +0200
commita513e0e89c206651e0557f13113704ddec2227ba (patch)
tree60db233d16c3798621cb50a92e835b7a9811bc99 /games-util
parentgames-emulation/duckstation: update live (diff)
downloadguru-a513e0e89c206651e0557f13113704ddec2227ba.tar.gz
guru-a513e0e89c206651e0557f13113704ddec2227ba.tar.bz2
guru-a513e0e89c206651e0557f13113704ddec2227ba.zip
games-util/itch-bin: Version bump 25.5.1.
- Unbundle libffmpeg.so and libvulkan.so - Use icon from zip - Fix desktop entry Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/itch-bin/Manifest1
-rw-r--r--games-util/itch-bin/itch-bin-25.5.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/games-util/itch-bin/Manifest b/games-util/itch-bin/Manifest
index f32ef703d..95229ea33 100644
--- a/games-util/itch-bin/Manifest
+++ b/games-util/itch-bin/Manifest
@@ -1,2 +1,3 @@
DIST itch-bin-25.4.0.zip 62941242 BLAKE2B c50f996f98f9ce6e845c44d6c5b176e321f885b7db70569ab5bf526fcc4b21ed1b3428022400457fbdac5c6f387b27865d4768f99c94e60bb18897e68a75a5b2 SHA512 6a0e6fbfba94c162052594ea0442062262690c4ef42889056c42c752cf95b6cabf501c32660c2ba71935a1b1bc0fab946435488385f96c2cd3ab672c9109019d
DIST itch-bin-25.4.1.zip 81376561 BLAKE2B 9235894252f811338c5ce535a31d52aaa5eeb2a3fc9684841401585e67e94adf135bc137d0b0551861c20039914f38b2f9881238be645ed7b23602229261ee01 SHA512 6c55b2716f64e8206ac6b885e2ec06eddd077dcf4aa9a8ebf17092a6e2c71ea40843cf0396f096264ba7408d559e33ce0e8b98215b299d1a89a749fc3ba7a11a
+DIST itch-bin-25.5.1.zip 81447648 BLAKE2B 5c0ef34b71d5ba1f771a8e8ba8fa9b012df17a2109061837af6a3d86e94c97a61c564d9752d550cc30be9f306543a622badc3c7165465a5c0fb48966f800a52e SHA512 17a55680570c6a2bf82336b1825742f6b1d64158c97cf1a8734688957d642e6ea48d9b9526fef9cf81f1c5869e5425111e90b94d2154966addd504dc3f66530d
diff --git a/games-util/itch-bin/itch-bin-25.5.1.ebuild b/games-util/itch-bin/itch-bin-25.5.1.ebuild
new file mode 100644
index 000000000..51f7a05e2
--- /dev/null
+++ b/games-util/itch-bin/itch-bin-25.5.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+DESCRIPTION="itch.io game browser, installer and launcher"
+HOMEPAGE="https://itch.io/"
+SRC_URI="https://broth.itch.ovh/itch/linux-amd64/${PV}/archive/default -> ${P}.zip"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="
+ x11-libs/gtk+:3[X,cups]
+ x11-libs/libXtst
+ gnome-base/gconf
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/freetype
+ x11-libs/pixman
+ media-libs/libpng:*
+ dev-libs/libpcre
+ net-dns/libidn2
+ net-libs/gnutls
+ dev-libs/libbsd
+ sys-apps/util-linux
+ media-gfx/graphite2
+ media-libs/vulkan-loader
+ media-video/ffmpeg[chromium]
+"
+
+QA_PREBUILT="
+ /opt/itch-bin/itch
+ /opt/itch-bin/libvk_swiftshader.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ local destdir="${EPREFIX}/opt/${PN}"
+ insinto "${destdir}"
+ doins -r locales resources
+ doins *.pak *.dat *.bin *.json version libvk_swiftshader.so
+
+ exeinto "${destdir}"
+ doexe itch
+ dosym "${destdir}/itch" /usr/bin/itch-bin
+
+ newicon -s 256 "resources/app/src/static/images/tray/itch.png" "${PN}.png"
+ newicon -s 128 "resources/app/src/static/images/window/itch/icon.png" "${PN}.png"
+
+ make_desktop_entry itch-bin Itch itch-bin "Network;Game"
+}