aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Postiglione <andrea.postiglione@gmail.com>2020-12-05 09:51:21 +0100
committerAndrea Postiglione <andrea.postiglione@gmail.com>2020-12-05 09:51:21 +0100
commite6260fd41a7a49838254e0e7094f49f490c88e16 (patch)
tree0b9125d07c036e2c310023e8f1cceb6666823953 /dev-ruby
parentdev-python/pywebview: drop old (diff)
downloadguru-e6260fd41a7a49838254e0e7094f49f490c88e16.tar.gz
guru-e6260fd41a7a49838254e0e7094f49f490c88e16.tar.bz2
guru-e6260fd41a7a49838254e0e7094f49f490c88e16.zip
dev-ruby/thin: 1.8.0 bin wrapper and so build
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Andrea Postiglione <andrea.postiglione@gmail.com>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thin/thin-1.8.0.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-ruby/thin/thin-1.8.0.ebuild b/dev-ruby/thin/thin-1.8.0.ebuild
index 73a6a76a1..c8c8ab1ae 100644
--- a/dev-ruby/thin/thin-1.8.0.ebuild
+++ b/dev-ruby/thin/thin-1.8.0.ebuild
@@ -21,3 +21,18 @@ DEPEND="dev-ruby/eventmachine
RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/thin_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/thin_parser
+ cp ext/thin_parser/thin_parser.so lib/ || die
+}
+
+
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper thin
+}