aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <WolfgangESanyer@gmail.com>2021-01-03 21:01:37 -0500
committerWolfgang E. Sanyer <WolfgangESanyer@gmail.com>2021-01-03 21:14:53 -0500
commit85cfd5f431dcfe4efd0561ae0598fa28d6b2214a (patch)
tree63ed1900e052ad0d82da27c0ea91fe12ca18e464 /dev-python/phx-class-registry
parentx11-misc/i3lock-color: depend x11-libs/libxkbcommon[X] (diff)
downloadguru-85cfd5f431dcfe4efd0561ae0598fa28d6b2214a.tar.gz
guru-85cfd5f431dcfe4efd0561ae0598fa28d6b2214a.tar.bz2
guru-85cfd5f431dcfe4efd0561ae0598fa28d6b2214a.zip
dev-python/phx-class-registry: new package, dep of b2
Signed-off-by: Wolfgang E. Sanyer <WolfgangESanyer@gmail.com>
Diffstat (limited to 'dev-python/phx-class-registry')
-rw-r--r--dev-python/phx-class-registry/Manifest1
-rw-r--r--dev-python/phx-class-registry/metadata.xml17
-rw-r--r--dev-python/phx-class-registry/phx-class-registry-3.0.5.ebuild18
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/phx-class-registry/Manifest b/dev-python/phx-class-registry/Manifest
new file mode 100644
index 000000000..4622fc776
--- /dev/null
+++ b/dev-python/phx-class-registry/Manifest
@@ -0,0 +1 @@
+DIST phx-class-registry-3.0.5.tar.gz 23756 BLAKE2B 7ba98323cb91a328b7dbe3df2def174d950c9f78da2fbd62c81dbf3803d570d42794a20ca3219b41f8f5b739efd3317ce8672f70169db492c2cda8a980460fb1 SHA512 324171cbf14132e02c58026d90c87d408fd321d95258cf8cd66de472a125177c4131ca1e47fad279db3384a8a3a50832eb1287a4b577c76c79a9391fa1d998c6
diff --git a/dev-python/phx-class-registry/metadata.xml b/dev-python/phx-class-registry/metadata.xml
new file mode 100644
index 000000000..4de28fe68
--- /dev/null
+++ b/dev-python/phx-class-registry/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ezzieyguywuf@gmail.com</email>
+ <name>Wolfgang E. Sanyer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ At the intersection of the Registry and Factory patterns lies the
+ ClassRegistry. This package contains the python modules necessary to use
+ this dessign pattern
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/phx-class-registry/phx-class-registry-3.0.5.ebuild b/dev-python/phx-class-registry/phx-class-registry-3.0.5.ebuild
new file mode 100644
index 000000000..282d9a8e8
--- /dev/null
+++ b/dev-python/phx-class-registry/phx-class-registry-3.0.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An intersection of the Registry and Factory pattern"
+HOMEPAGE="https://github.com/todofixthis/class-registry"
+SRC_URI="https://github.com/todofixthis/class-registry/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/class-registry-${PV}"
+
+distutils_enable_tests nose