aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tokunaga <tokusan441@gmail.com>2024-08-02 12:42:36 +0900
committerHiroki Tokunaga <tokusan441@gmail.com>2024-08-02 12:42:36 +0900
commit9435fea9eb08dd64309e85165df5fab7856125f0 (patch)
tree11e07b1ee1966b5fc0c5d5a5e496f993c7d7c5f2 /dev-ml/ocamlc-loc
parentdev-ml/dune-rpc: add 3.16.0 (diff)
downloadguru-9435fea9eb08dd64309e85165df5fab7856125f0.tar.gz
guru-9435fea9eb08dd64309e85165df5fab7856125f0.tar.bz2
guru-9435fea9eb08dd64309e85165df5fab7856125f0.zip
dev-ml/ocamlc-loc: add 3.16.0
Signed-off-by: Hiroki Tokunaga <tokusan441@gmail.com>
Diffstat (limited to 'dev-ml/ocamlc-loc')
-rw-r--r--dev-ml/ocamlc-loc/Manifest1
-rw-r--r--dev-ml/ocamlc-loc/ocamlc-loc-3.16.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocamlc-loc/Manifest b/dev-ml/ocamlc-loc/Manifest
index f173e2e8c..8ab475eb4 100644
--- a/dev-ml/ocamlc-loc/Manifest
+++ b/dev-ml/ocamlc-loc/Manifest
@@ -1 +1,2 @@
DIST ocamlc-loc-3.13.1.tar.gz 2891852 BLAKE2B 88cee2428134ddcd6b929915b6bbeb2d17be8b8190f963919a74c63ffcf80f596fb1556f88c41ee602b2386e02fdf396596a6b2097d67c720bd00e16cdda3a57 SHA512 910d4ddd55a91ee65d8ea35b8915506db74c924eb3b67f7b0715da5599ee5088ea3edec81ce6735addd5b17234e445608e59fa353b83e991c14768d83c97a2b5
+DIST ocamlc-loc-3.16.0.tar.gz 2999701 BLAKE2B 5e371fa1003cec31273aeeb1a830036f48d3734588bd7a980b57aaae30d4984a34dec6f9be0ee9985c72dee08c2c6d456a789eab83cfce42c142a3abc6951b2e SHA512 3b1d041907128b6598e0f6150fe300a4a69098822f823ceead63b46e1005a21485738c6fa92641dd940c9f9cde48ae141ea51959a9b250bee3cbeb06ba788e23
diff --git a/dev-ml/ocamlc-loc/ocamlc-loc-3.16.0.ebuild b/dev-ml/ocamlc-loc/ocamlc-loc-3.16.0.ebuild
new file mode 100644
index 000000000..c09efeec2
--- /dev/null
+++ b/dev-ml/ocamlc-loc/ocamlc-loc-3.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parse ocaml compiler output into structured form"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/ocamlc-loc/
+ https://github.com/ocaml/dune
+"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+
+SLOT="0/${PV}"
+
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=
+ ~dev-ml/dune-private-libs-${PV}:=
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ >=dev-ml/dune-3.12:=
+"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ocamlc-loc
+}