aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-12-13 11:14:53 -0500
committerAisha Tammy <gentoo@aisha.cc>2020-12-13 11:14:53 -0500
commit48f3918ec35a8f22d02613b111c4c2746a7e70d2 (patch)
treead480dd669891c0b7ce475ddb6c9dcd2f71f1db4 /dev-libs/imsg-compat
parentsys-fs/dwarfs: updated to 0.2.4 (diff)
downloadguru-48f3918ec35a8f22d02613b111c4c2746a7e70d2.tar.gz
guru-48f3918ec35a8f22d02613b111c4c2746a7e70d2.tar.bz2
guru-48f3918ec35a8f22d02613b111c4c2746a7e70d2.zip
dev-libs/imsg-compat: version bump to 6.8.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'dev-libs/imsg-compat')
-rw-r--r--dev-libs/imsg-compat/Manifest1
-rw-r--r--dev-libs/imsg-compat/imsg-compat-6.8.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/imsg-compat/Manifest b/dev-libs/imsg-compat/Manifest
index 2b26e70af..f8dc9f787 100644
--- a/dev-libs/imsg-compat/Manifest
+++ b/dev-libs/imsg-compat/Manifest
@@ -1 +1,2 @@
DIST imsg-compat-6.8.0.tar.gz 10827 BLAKE2B 81471bf67d855e200271e66de854b5e09ddee718b2809e46a16e6ad30d8956910ff15c3e2ae353f12d2cf020cfc1b18010638f000188765807b9f9cd68e34642 SHA512 270ec6e5a6f0f05cf074c4659a508f3f43379f9aa424f4d8d1fec9e6107d97026aca2517ae843c51a240b0e504f4c9368109d842fc018f3aa1be77ce9eac29b4
+DIST imsg-compat-6.8.1.tar.gz 11378 BLAKE2B f48baba739a38525e6271138f332b9c0233858354fcf12f477a4d993d351568d1c1e2baad826f581f31fa332655e728cb97655bfc193e8bc02cf0309dca4fa0b SHA512 ce66816a8c19594598b7fad7965bb1a30723277f86ff91c49e80eaa0aa075fc8c367f93425b204b96b1abefd8c5cde840d4b7db799228d6e6b7d1732e8742a4b
diff --git a/dev-libs/imsg-compat/imsg-compat-6.8.1.ebuild b/dev-libs/imsg-compat/imsg-compat-6.8.1.ebuild
new file mode 100644
index 000000000..5cdcd0124
--- /dev/null
+++ b/dev-libs/imsg-compat/imsg-compat-6.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="linux port of OpenBSD imsg"
+
+HOMEPAGE="https://man.openbsd.org/imsg_init.3
+ https://github.com/bsd-ac/imsg-compat
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bsd-ac/imsg-compat.git"
+else
+ SRC_URI="https://github.com/bsd-ac/imsg-compat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ if ! use static-libs ; then
+ find "${ED}"/usr/$(get_libdir) -name "*.a" -delete || die
+ fi
+}