aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-09 07:32:59 +0800
committerRoss Charles Campbell <rossbridger.cc@gmail.com>2021-05-09 07:35:28 +0800
commit121287dfc57a06589b25465a8e953699073f6164 (patch)
tree10266246777643f6e0f0383215ddcbb513a86b7f /dev-games
parentapp-editors/visual-studio-code-bin: Version bump, remove old (diff)
downloadguru-121287dfc57a06589b25465a8e953699073f6164.tar.gz
guru-121287dfc57a06589b25465a8e953699073f6164.tar.bz2
guru-121287dfc57a06589b25465a8e953699073f6164.zip
dev-games/godot: disable raycast module
Since embree (https://github.com/embree/embree) is not landed at the moment, raycast module is disabled for the moment. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/godot/godot-3.3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-games/godot/godot-3.3.ebuild b/dev-games/godot/godot-3.3.ebuild
index 29a02956d..fa2e46cd3 100644
--- a/dev-games/godot/godot-3.3.ebuild
+++ b/dev-games/godot/godot-3.3.ebuild
@@ -73,6 +73,7 @@ src_configure() {
# Remove builtin third-party packages, link with system ones instead
myesconsargs+=(
builtin_bullet=no
+ builtin_embree=no
builtin_enet=no
builtin_freetype=no
builtin_libogg=no
@@ -92,6 +93,9 @@ src_configure() {
myesconsargs+=(
# Mono bindings requires MSBuild which is only available on Windows
module_mono_enabled=no
+ # TODO: land embree library (https://github.com/embree/embree) in guru
+ # so that we can enable raycast module
+ module_raycast_enabled=no
module_bullet_enabled=$(usex bullet)
module_enet_enabled=$(usex enet)
module_freetype_enabled=$(usex freetype)
@@ -137,6 +141,6 @@ src_install() {
insinto /usr/share/metainfo
doins misc/dist/linux/org.godotengine.Godot.appdata.xml
insinto /usr/share/mime/application
- doins misc/dist/linux/x-godot-project.xml
+ doins misc/dist/linux/org.godotengine.Godot.xml
dodoc AUTHORS.md CHANGELOG.md DONORS.md README.md
}