aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-05-11 12:39:45 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2022-05-11 12:42:41 +0200
commitb1d84eaabe01ac0091d1240b0d6d0b76ee8009b8 (patch)
treef428f71ae9bc318f4a0ca657c8981d7c583786b9 /dev-db
parentdev-python/python-betterproto: removed keywords arm64 loong mips (diff)
downloadguru-b1d84eaabe01ac0091d1240b0d6d0b76ee8009b8.tar.gz
guru-b1d84eaabe01ac0091d1240b0d6d0b76ee8009b8.tar.bz2
guru-b1d84eaabe01ac0091d1240b0d6d0b76ee8009b8.zip
dev-db/rum: add 1.3.9
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/rum/Manifest1
-rw-r--r--dev-db/rum/rum-1.3.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/rum/Manifest b/dev-db/rum/Manifest
index 098691a62..f0cd0b78c 100644
--- a/dev-db/rum/Manifest
+++ b/dev-db/rum/Manifest
@@ -1 +1,2 @@
DIST rum-1.3.7.tar.gz 314685 BLAKE2B 0e54a935460b230dfc5ed26413118d0009d42feb823f19c094b738e737e4b6a23447a488cd6512bb854256c08e2797f58947c384dafb63d0d010c2686bfe11db SHA512 fecbeac6145e37f76e2425a1db40e2dae7912763be5150ef1f00daba176843f0c5ff32311d45819c2fb085ad8b15793bbd284797074d24c2bc0f4a331b24e82c
+DIST rum-1.3.9.tar.gz 315642 BLAKE2B ce80dcd10171b6cbe502da669ff7ba94a8971ff6a9494061d36ca9167fca24d3e4af87586babc6e0cfccd347ce8ead769c8cc79ce004374831797e82ead0f7b8 SHA512 7fb6afe44fe8829aa764bca51b9cc1d03bfdd99b3337ea4c5c1efbd00f66e14279e38139a8e6755e2d56ab1cb8cec754a1c4f40f51f7c7ee9ea813313ff31e5c
diff --git a/dev-db/rum/rum-1.3.9.ebuild b/dev-db/rum/rum-1.3.9.ebuild
new file mode 100644
index 000000000..49a290c57
--- /dev/null
+++ b/dev-db/rum/rum-1.3.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 10 11 12 13 14 )
+POSTGRES_USEDEP="server"
+
+inherit postgres-multi
+
+DESCRIPTION="RUM access method - inverted index with additional information in posting lists"
+HOMEPAGE="https://github.com/postgrespro/rum"
+SRC_URI="https://github.com/postgrespro/rum/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+# Needs a running PostgreSQL server
+RESTRICT="test"
+
+src_compile() {
+ postgres-multi_foreach emake USE_PGXS=1
+}
+
+src_test() {
+ postgres-multi_foreach emake USE_PGXS=1 installcheck
+}
+
+src_install() {
+ postgres-multi_foreach emake USE_PGXS=1 DESTDIR="${D}" install
+}