aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2023-10-29 13:35:43 +0100
committerAdrian Schollmeyer <nex+b-g-o@nexadn.de>2023-10-29 13:35:43 +0100
commit3d66217243d33e6016fcb65b17b8434329243d8e (patch)
tree45b0d6d83b896bd12b3b3e5fd73bcc2a5a75c8be /app-vim
parentnet-vpn/mullvadvpn-app: fix unresolved SONAME dependencies (diff)
downloadguru-3d66217243d33e6016fcb65b17b8434329243d8e.tar.gz
guru-3d66217243d33e6016fcb65b17b8434329243d8e.tar.bz2
guru-3d66217243d33e6016fcb65b17b8434329243d8e.zip
app-vim/ansible-vim: add 3.4
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/ansible-vim/Manifest1
-rw-r--r--app-vim/ansible-vim/ansible-vim-3.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/ansible-vim/Manifest b/app-vim/ansible-vim/Manifest
index b5140fea7..e535a2219 100644
--- a/app-vim/ansible-vim/Manifest
+++ b/app-vim/ansible-vim/Manifest
@@ -1,2 +1,3 @@
DIST ansible-vim-3.2.tar.gz 12116 BLAKE2B e532b348216f3616060b9e09d177d601534c37eda1305512309954e0480e2827bd6f2d40564151104184a389c495b2442264f34d5b8031a1023ddd093cdd1be6 SHA512 a75e8b149befb001fdb0012ea8219287a6b4c302e2ae2de456835c48e3a516bb99bfb91a21e2d60eff12b5a24d918510dd9302d93e0bf43cb42f025ea0504d1b
DIST ansible-vim-3.3.tar.gz 12887 BLAKE2B 036cfdbdefb7d4992700476556a2805a3bc9cfba9e98d793eea7526fc2587a23ed34e64cfc141a54d9f435e957db7315b6549190de7dde3b619fe4360af238bb SHA512 7848e91ebf43d9581773436eca4310c5a26f743f2384d9cfc2e430a7b84fd945c4cd65aeb54947c47e3903e1fccb275d94bcfa22f6660e3438cc9785c38ca10f
+DIST ansible-vim-3.4.tar.gz 13049 BLAKE2B 7fed011b0eefcae16d5e6688fe722c37e43b43445288affb652fbefe9e183469965c2aa97fa27dcddcb866a08d8f9ba438d931ff1698d6bb4105f1dfe8a35999 SHA512 c301663e54c7724ff6cc268d4254c96fa7b100860b87584e6615b778a9b8f9e6839d207be6b765c2e85362104a8336e119dfdef995173f48d2f2b108762b6d90
diff --git a/app-vim/ansible-vim/ansible-vim-3.4.ebuild b/app-vim/ansible-vim/ansible-vim-3.4.ebuild
new file mode 100644
index 000000000..922948793
--- /dev/null
+++ b/app-vim/ansible-vim/ansible-vim-3.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sytax highlighting for Ansible's common file types"
+HOMEPAGE="https://github.com/pearofducks/ansible-vim"
+SRC_URI="https://github.com/pearofducks/ansible-vim/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT BSD"
+KEYWORDS="~amd64"
+
+src_install() {
+ vim-plugin_src_install
+
+ find "${ED}" -name "*LICENSE" -delete || die
+}