aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahul Sandhu <rahul@sandhuservices.dev>2023-04-16 10:12:10 +0100
committerRahul Sandhu <rahul@sandhuservices.dev>2023-04-16 10:12:10 +0100
commit0a9316ef0ebc53300338b04925c6a163238fd532 (patch)
treeccb3d8bb97cc2fe4c845a9720fc2a33ed9783aa4 /app-office
parentgui-wm/swayfx: add github upstream metadata (diff)
downloadguru-0a9316ef0ebc53300338b04925c6a163238fd532.tar.gz
guru-0a9316ef0ebc53300338b04925c6a163238fd532.tar.bz2
guru-0a9316ef0ebc53300338b04925c6a163238fd532.zip
app-office/obsidian: new package, add 1.1.16
Signed-off-by: Rahul Sandhu <rahul@sandhuservices.dev>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/obsidian/Manifest1
-rw-r--r--app-office/obsidian/metadata.xml9
-rw-r--r--app-office/obsidian/obsidian-1.1.16.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/app-office/obsidian/Manifest b/app-office/obsidian/Manifest
new file mode 100644
index 000000000..9f265465d
--- /dev/null
+++ b/app-office/obsidian/Manifest
@@ -0,0 +1 @@
+DIST obsidian_1.1.16_amd64.deb 69117356 BLAKE2B 3ae0d9bd36e2048ff55e0a8757668e7e8b4de43dd3c658d263345181030f89bcbb3ddb005c317c432771f8d4f38185693ea30206e579612b99fde3c761b31352 SHA512 09f203890b1a445051dd4f7a18584a78b30e6083101ec660b63dff01ab4b6c2ab57fb2665e36cd4ddf5534f31afbb32bb9fd718dc76df5778b11038a09c0170f
diff --git a/app-office/obsidian/metadata.xml b/app-office/obsidian/metadata.xml
new file mode 100644
index 000000000..6c1e2f683
--- /dev/null
+++ b/app-office/obsidian/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rahul@sandhuservices.dev</email>
+ <name>Rahul Sandhu</name>
+ </maintainer>
+ <longdescription lang="en">A second brain, for you, forever.</longdescription>
+</pkgmetadata>
diff --git a/app-office/obsidian/obsidian-1.1.16.ebuild b/app-office/obsidian/obsidian-1.1.16.ebuild
new file mode 100644
index 000000000..db9d93c65
--- /dev/null
+++ b/app-office/obsidian/obsidian-1.1.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg
+
+DESCRIPTION="A second brain, for you, forever."
+HOMEPAGE="https://obsidian.md"
+SRC_URI="https://github.com/obsidianmd/obsidian-releases/releases/download/v${PV}/${PN}_${PV}_amd64.deb"
+
+LICENSE="Obsidian-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /opt/Obsidian
+ doins -r opt/Obsidian/*
+
+ domenu usr/share/applications/obsidian.desktop
+
+ for size in 16 32 48 64 128 256 512; do
+ doicon --size "${size}" "usr/share/icons/hicolor/${size}x${size}/apps/${PN}.png"
+ done
+
+ fperms 4755 /opt/Obsidian/chrome-sandbox || die
+ fperms +x /opt/Obsidian/obsidian || die
+
+ dosym ../../opt/Obsidian/obsidian /usr/bin/obsidian
+}