aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Grinberg <codeswhite@protonmail.com>2021-09-05 22:24:09 +0300
committerMax Grinberg <codeswhite@protonmail.com>2021-09-05 22:24:37 +0300
commitef71fd6c4c04e393f596d3c8eab828144be693e8 (patch)
treee508d054f6e9b6020e115055e9ef8bceb0ee5088 /app-admin
parentsys-fs/gfs2-utils: version bump to 3.4.1 (diff)
downloadguru-ef71fd6c4c04e393f596d3c8eab828144be693e8.tar.gz
guru-ef71fd6c4c04e393f596d3c8eab828144be693e8.tar.bz2
guru-ef71fd6c4c04e393f596d3c8eab828144be693e8.zip
app-admin/grub-customizer: New package v5.1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Max Grinberg <codeswhite@protonmail.com>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/grub-customizer/Manifest1
-rw-r--r--app-admin/grub-customizer/grub-customizer-5.1.0.ebuild39
-rw-r--r--app-admin/grub-customizer/metadata.xml14
3 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/grub-customizer/Manifest b/app-admin/grub-customizer/Manifest
new file mode 100644
index 000000000..2d50cbb5b
--- /dev/null
+++ b/app-admin/grub-customizer/Manifest
@@ -0,0 +1 @@
+DIST grub-customizer_5.1.0.tar.gz 578046 BLAKE2B 3d32db2523e70968786bd2d6b620ee3a42a312d0b892e38121b8869a155c23aa5ead9219e56e0a84109c0bcf84a4c1f00130a3565c8d28c77b1e23bbf669a2c4 SHA512 d79c7996afd8486483d4460432207dc19315d7377dcfd2fd6a4594e64c6750bbae36f96c395c4a9748d0ff43c6095399d822fc6a23beedbc8769802818dfa11f
diff --git a/app-admin/grub-customizer/grub-customizer-5.1.0.ebuild b/app-admin/grub-customizer/grub-customizer-5.1.0.ebuild
new file mode 100644
index 000000000..ac63aa61b
--- /dev/null
+++ b/app-admin/grub-customizer/grub-customizer-5.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A graphical grub2 settings manager"
+HOMEPAGE="https://launchpad.net/grub-customizer"
+SRC_URI="https://launchpad.net/grub-customizer/5.1/5.1.0/+download/grub-customizer_5.1.0.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-cpp/gtkmm:3.0
+ dev-libs/openssl
+ x11-themes/hicolor-icon-theme
+ sys-boot/grub:2
+ sys-apps/hwinfo
+ app-arch/libarchive"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ CMAKE_BUILD_TYPE="release"
+ glib_path="/usr/include/"$(ls /usr/include/ | sed -n "/^glib-/p")
+ local mycmakeargs=(-DCMAKE_INSTALL_PREFIX=/usr -DEO_SOURCE_DIR:PATH=$glib_path)
+ append-cxxflags -I$glib_path -std=c++11
+ append-cflags -I$glib_path
+ #append-cppflags -I$glib_path -std=c++11
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ insinto /etc/grub-customizer
+}
diff --git a/app-admin/grub-customizer/metadata.xml b/app-admin/grub-customizer/metadata.xml
new file mode 100644
index 000000000..30fb43bb0
--- /dev/null
+++ b/app-admin/grub-customizer/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>codeswhite@pm.me</email>
+ <name>Max Grinberg</name>
+ </maintainer>
+ <longdescription lang="en">
+ Grub Customizer is a graphical interface to configure the GRUB2/BURG settings and menuentries
+ </longdescription>
+ <upstream>
+ <remote-id type="launchpad">grub-customizer</remote-id>
+ </upstream>
+</pkgmetadata>