aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-07-28 23:08:08 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-07-28 23:08:08 +0200
commit03edf5f64e781980bda5ea64e8e7a4accd0b2c20 (patch)
tree93adbb2addae74292f9a7eff7f69194e3233cd80 /app-admin
parentapp-admin/rbw: advertise optional Wayland clipboard support (diff)
downloadguru-03edf5f64e781980bda5ea64e8e7a4accd0b2c20.tar.gz
guru-03edf5f64e781980bda5ea64e8e7a4accd0b2c20.tar.bz2
guru-03edf5f64e781980bda5ea64e8e7a4accd0b2c20.zip
app-admin/rbw: sync live ebuild
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/rbw/rbw-9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-admin/rbw/rbw-9999.ebuild b/app-admin/rbw/rbw-9999.ebuild
index 2e93ac20b..154a188e7 100644
--- a/app-admin/rbw/rbw-9999.ebuild
+++ b/app-admin/rbw/rbw-9999.ebuild
@@ -25,7 +25,7 @@ LICENSE+=" openssl"
SLOT="0"
RDEPEND="app-crypt/pinentry"
-BDEPEND=">=virtual/rust-1.74"
+BDEPEND=">=virtual/rust-1.75.0"
PATCHES="${FILESDIR}"/${PN}-1.11.1-gen-completions.patch
@@ -64,6 +64,12 @@ src_install() {
}
pkg_postinst() {
+ if [[ "${REPLACING_VERSIONS%-r*}" = '1.11.1' ]]; then
+ elog "If you were affected by issue #163 (getting messages like failed to"
+ elog "decrypt encrypted secret: invalid mac when doing any operations on your"
+ elog "vault), you will need to rbw sync after upgrading in order to update"
+ elog "your local vault with the necessary new data."
+ fi
# copypasta crate provides wayland clipboard support via dlopen calls against
# libwayland-client.so
optfeature "Wayland clipboard support" dev-libs/wayland