aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Burch <eli.burch@burchbytes.com>2024-06-14 13:29:23 -0700
committerEli Burch <eli.burch@burchbytes.com>2024-06-14 13:29:23 -0700
commitf5d25f95a81aea2ea9abd32f61b5be84661e39ba (patch)
tree0039cef1c5918bfbc74bcd35cf1b1b65e24c93c3
parentnet-wireless/airspyhf: new package 1.6.8 (diff)
downloadguru-f5d25f95a81aea2ea9abd32f61b5be84661e39ba.tar.gz
guru-f5d25f95a81aea2ea9abd32f61b5be84661e39ba.tar.bz2
guru-f5d25f95a81aea2ea9abd32f61b5be84661e39ba.zip
net-wireless/airspyhf: Remove duplicate license, fix udevrules use flag
Signed-off-by: Eli Burch <eli.burch@burchbytes.com>
-rw-r--r--licenses/BSD-3-clause29
-rw-r--r--net-wireless/airspyhf/airspyhf-1.6.8.ebuild19
2 files changed, 17 insertions, 31 deletions
diff --git a/licenses/BSD-3-clause b/licenses/BSD-3-clause
deleted file mode 100644
index ef18f7cc9..000000000
--- a/licenses/BSD-3-clause
+++ /dev/null
@@ -1,29 +0,0 @@
-BSD 3-Clause License
-
-Copyright (c) 2017, Airspy
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-* Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-
-* Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-* Neither the name of the copyright holder nor the names of its
- contributors may be used to endorse or promote products derived from
- this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/net-wireless/airspyhf/airspyhf-1.6.8.ebuild b/net-wireless/airspyhf/airspyhf-1.6.8.ebuild
index cfb485f1f..16f619d61 100644
--- a/net-wireless/airspyhf/airspyhf-1.6.8.ebuild
+++ b/net-wireless/airspyhf/airspyhf-1.6.8.ebuild
@@ -7,7 +7,7 @@ DESCRIPTION="User mode driver for Airspy HF+"
HOMEPAGE="https://airspy.com/airspy-hf-plus/"
SRC_URI="https://github.com/airspy/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD-3-clause"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
@@ -15,13 +15,28 @@ IUSE="udevrules"
DEPEND="dev-build/cmake
dev-libs/libusb
dev-util/pkgconf"
-inherit cmake
+inherit cmake udev
RDEPEND="${DEPEND}"
+src_prepare(){
+ ls
+ sed -i 's@DESTINATION "/etc/udev/rules.d"@DESTINATION "/lib/udev/rules.d"@' "tools/CMakeLists.txt" || die
+
+ cmake_src_prepare
+}
+
src_configure(){
mycmakeargs+=(
-DINSTALL_UDEV_RULES=$(usex udevrules)
)
cmake_src_configure
}
+
+pkg_postinst(){
+ udev_reload
+}
+
+pkg_postrm(){
+ udev_reload
+}