aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-09-29 22:03:29 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:30:42 +0200
commite802de8c31fd9d827662bdd8e94fae5f93f0901e (patch)
treed2e0ea25992edbdb841f5ec281401ca053a02099
parentdev-R/lattice: version bump to 0.20.44 (diff)
downloadguru-e802de8c31fd9d827662bdd8e94fae5f93f0901e.tar.gz
guru-e802de8c31fd9d827662bdd8e94fae5f93f0901e.tar.bz2
guru-e802de8c31fd9d827662bdd8e94fae5f93f0901e.zip
dev-python/pysaml2: add 7.0.1, drop 6.1.0
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pysaml2/Manifest2
-rw-r--r--dev-python/pysaml2/pysaml2-7.0.1.ebuild (renamed from dev-python/pysaml2/pysaml2-6.1.0.ebuild)22
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-python/pysaml2/Manifest b/dev-python/pysaml2/Manifest
index 0123be1ab..bd76ef2a7 100644
--- a/dev-python/pysaml2/Manifest
+++ b/dev-python/pysaml2/Manifest
@@ -1 +1 @@
-DIST pysaml2-6.1.0.tar.gz 325101 BLAKE2B 254d1c57e03f13346db89ee18a885d03ce55ed6eec5649d5c764ed6bf97ff20e2a0715e5678409125737acf8fda464c331a17ebe422cc96518bdd3825cf8db05 SHA512 4b3f942a352e6e9ad8df9d3c41269d00dda9f4a71286a4030556d35e5e3946c214fa5c2942f529b1f1ee4dfc30a4d388dffa204f6bdc7614f65b8a3a37ea5ff9
+DIST pysaml2-7.0.1.tar.gz 359067 BLAKE2B 1a420c40ab34e290cf0ccb1b58ffc01081db540eda0281aa67b37722c39fd6abd6a806e3d8c564ff7af777c922359e632be30c344837ad8eb9e035cfa921400c SHA512 a706136628c1b86b2d53ea64e6506cf4b1ce2722e3583ed0dd39125ee9e898d4309224a0d3baa2c6a4f8adeba22e4e18945113da628659476d5f77f297daef60
diff --git a/dev-python/pysaml2/pysaml2-6.1.0.ebuild b/dev-python/pysaml2/pysaml2-7.0.1.ebuild
index 3be144be9..8ac8c5ab9 100644
--- a/dev-python/pysaml2/pysaml2-6.1.0.ebuild
+++ b/dev-python/pysaml2/pysaml2-7.0.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI=8
+
DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_8 )
inherit distutils-r1
@@ -13,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64"
RDEPEND="
>=dev-python/cryptography-1.4[${PYTHON_USEDEP}]
@@ -23,4 +24,17 @@ RDEPEND="
dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ >=dev-python/xmlschema-1.2.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
"
+
+distutils_enable_tests pytest