aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-03-31 20:33:22 +0300
committerViorel Munteanu <ceamac.paragon@gmail.com>2022-03-31 20:33:22 +0300
commit181c638d7d81281ad422258a214d6ec9c4a96d20 (patch)
tree5c54f1e19c4767eb1b540f9e42eee6f98f386985
parentnet-misc/maestral: add 1.6.1 (diff)
downloadguru-181c638d7d81281ad422258a214d6ec9c4a96d20.tar.gz
guru-181c638d7d81281ad422258a214d6ec9c4a96d20.tar.bz2
guru-181c638d7d81281ad422258a214d6ec9c4a96d20.zip
net-misc/maestral: drop 1.6.0
Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com>
-rw-r--r--net-misc/maestral/Manifest1
-rw-r--r--net-misc/maestral/maestral-1.6.0.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/net-misc/maestral/Manifest b/net-misc/maestral/Manifest
index 47c185b3d..c09e40948 100644
--- a/net-misc/maestral/Manifest
+++ b/net-misc/maestral/Manifest
@@ -1,4 +1,3 @@
DIST maestral-1.5.2.tar.gz 8277812 BLAKE2B df901a0a98a51f3c611cd3aa3ff4d4662fa10cdd595df2214f1a4c9fd0da8c787531a21671261df7196869d1822c69884299f2bcecd0e4190bb81fcb55a8885f SHA512 eafed2a3dbc55e3ee9417da393864ec94c76724949855805e99e3c65c29b1d33aeeb2ac063c0a4c115d3f03c002dbe899b6ec1ec6ebcb0a29386a39eabdeb769
DIST maestral-1.5.3.tar.gz 8280040 BLAKE2B dcda43880cea3fb00098b6bf87e43318a523a7c9d83886efff58be715cde17f67504b31735a006b951963e5cf0ef70b4b6431cb84200722cae186053a01edd63 SHA512 aa21277623f4e6f3283cd989be910eeb1caa3a842abca595b27a551c1c9bd1e7ef083e495ee0f096190accd91835939cb2f4a26624feae0046d8770d53aaac2f
-DIST maestral-1.6.0.tar.gz 8285354 BLAKE2B 05cfaee17018be913d89d9eee6b648bd18c377e1dd7a877d21fdb018a874b638d8254de83ea39c461daf30b1d953b9dc09e5d26c095dacacd8fe6783eb2d8c6e SHA512 1a0dec0d9f644ba8c5584ceb601d6b5fb617a19b3571352e52b8c8b5709cca392710fb8ee2a062f7612bd0d5d1047e51192366b1134f912eb05813b6b33afd9a
DIST maestral-1.6.1.tar.gz 8286154 BLAKE2B 23fcb8e2cb8a84e49ce1badde0ed70d63f7f8b9eeef2c748d49d0439434c7a568dcf8edd009a5d5f12646d2370f117debe0f3ba1fad84148483b952b0140a9b6 SHA512 287d5022c31f001c018a68723c0f97f6bb74db6c68c2083423e34fc11bb31f0bb9c9c1bc8f558d35dbe341667fd89d1d6ec99d020f435f1d05a0ffbc44ada85d
diff --git a/net-misc/maestral/maestral-1.6.0.ebuild b/net-misc/maestral/maestral-1.6.0.ebuild
deleted file mode 100644
index 6af2d0e6c..000000000
--- a/net-misc/maestral/maestral-1.6.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
-HOMEPAGE="https://maestral.app"
-SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
- >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/dropbox-sdk-python-11.28.0[${PYTHON_USEDEP}]
- <dev-python/dropbox-sdk-python-12.0.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
- >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
- >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
- >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
- >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
- >=dev-python/sdnotify-0.3.2[${PYTHON_USEDEP}]
- >=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
- <dev-python/survey-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_8)
-"
-BDEPEND="
- dev-python/build[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-benchmark[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all()
-{
- # this test requires systemd
- sed -i -e 's/test_autostart/_&/' tests/offline/test_cli.py || die
-
- # this test requires network
- sed -i -e 's/test_check_for_updates/_&/' tests/offline/test_main.py || die
-
- distutils-r1_python_prepare_all
-}