aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2016-12-02 14:04:14 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2016-12-02 14:04:14 +0400
commit6d9b63cc677d29079eff7ed21c839cce6f2c7662 (patch)
tree30c6aa776267ae31bcd57282cadd0ff1a6b39ca6 /dev-lang
parentMerge pull request #273 from ArsenShnurkov/libgit2sharp (diff)
downloaddotnet-6d9b63cc677d29079eff7ed21c839cce6f2c7662.tar.gz
dotnet-6d9b63cc677d29079eff7ed21c839cce6f2c7662.tar.bz2
dotnet-6d9b63cc677d29079eff7ed21c839cce6f2c7662.zip
remove nightly mono
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-4.9.0.729-r2.ebuild121
2 files changed, 0 insertions, 122 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
deleted file mode 100644
index a26d89e..0000000
--- a/dev-lang/mono/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mono-4.9.0.729.tar.bz2 100437013 SHA256 05dcd396c29d40ccc0c4985138bcbd7abca1c326b69c3a85edbc21d8bb5448ef SHA512 7db4b184a2cb6d8aec19cb9e7efd4bbd6fb1c3910bd7141c1109242dd9c389b33403ba28de8bd42c6af5620e92af4c8f79fef0eef2428c53960fc78077f1f973 WHIRLPOOL 070cc2a47ff2f87d7953d50e63c4d379961cb39fcc8009fe19ee7f2ca77fd65ff9f66e7b3844b0b33e89d41ac2d82876b07eec7bf63863a51932161aa4dae065
diff --git a/dev-lang/mono/mono-4.9.0.729-r2.ebuild b/dev-lang/mono/mono-4.9.0.729-r2.ebuild
deleted file mode 100644
index 482dedb..0000000
--- a/dev-lang/mono/mono-4.9.0.729-r2.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.mono-project.com/Main_Page"
-SRC_URI="http://download.mono-project.com/sources/${PN}/nightly/${P}.tar.bz2"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-
-IUSE="nls minimal pax_kernel xen doc"
-
-COMMONDEPEND="
- !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
- ia64? ( sys-libs/libunwind )
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )
-"
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- virtual/yacc
- pax_kernel? ( sys-apps/elfix )
- !dev-lang/mono-basic
-"
-
-S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
-
-pkg_pretend() {
- # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
- # If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling.
- # See http://bugs.gentoo.org/261869 for more info."
- CONFIG_CHECK="SYSVIPC"
- use kernel_linux && check_extra_config
-}
-
-multilib_src_install_all() {
- insinto "/"
- doins "${S}/mcs/class/mono.snk"
-}
-
-pkg_preinst() {
- einfo D="${D}"
- MONO_EXECUTABLE="${WORKDIR}/mono-4.9.0-abi_x86_32.x86/mono/mini/mono-sgen"
- if [ ! -f "${MONO_EXECUTABLE}" ]; then
- die "${MONO_EXECUTABLE}, MONO_EXECUTABLE is missing"
- fi
- SN_ASSEMBLY="${WORKDIR}/mono-4.9.0-abi_x86_32.x86/mcs/tools/security/sn.exe"
- if [ ! -f "${SN_ASSEMBLY}" ]; then
- die "${SN_ASSEMBLY}, SN_ASSEMBLY is missing"
- fi
- SNK_FILE="${D}/mono.snk"
- if [ ! -f "${SNK_FILE}" ]; then
- die "${SNK_FILE}, SNK_FILE is missing"
- fi
- "${MONO_EXECUTABLE}" "${SN_ASSEMBLY}" -i "${SNK_FILE}" "mono" || die
- rm "${SNK_FILE}" || die
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- mono-env_pkg_setup
-}
-
-src_prepare() {
- # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTECT is enable. #286280
- # RANDMMAP kill the build proces to #347365
- # use paxmark.sh to get PT/XT logic #532244
- if use pax_kernel ; then
- ewarn "We are disabling MPROTECT on the mono binary."
-
- # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
- fi
-
- # mono build system can fail otherwise
- strip-flags
-
- eapply "${FILESDIR}/autofac.patch"
-
- default
- #eapply_user
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-silent-rules
- $(use_with xen xen_opt)
- --without-ikvm-native
- --disable-dtrace
- $(use_with doc mcs-docs)
- $(use_enable nls)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- cd mcs/tests || die
- emake check
-}
-
-multilib_src_install() {
- default_src_install
-
- # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
- # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
- # for reference.
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
-}