aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <-v>2015-06-21 17:37:49 +0300
committerlayman <-v>2015-06-21 17:37:49 +0300
commit64be044f3ada04eb29a440e0e383f66947d656bf (patch)
tree1a934ccf7c391afbddf3b6af2314c94926836e21 /app-shells
parentmetadata for debug flag was added (diff)
downloaddotnet-64be044f3ada04eb29a440e0e383f66947d656bf.tar.gz
dotnet-64be044f3ada04eb29a440e0e383f66947d656bf.tar.bz2
dotnet-64be044f3ada04eb29a440e0e383f66947d656bf.zip
fixes for repoman
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pash/pash-0.0-r20150618.ebuild31
1 files changed, 15 insertions, 16 deletions
diff --git a/app-shells/pash/pash-0.0-r20150618.ebuild b/app-shells/pash/pash-0.0-r20150618.ebuild
index 1cb27fc..6f0268a 100644
--- a/app-shells/pash/pash-0.0-r20150618.ebuild
+++ b/app-shells/pash/pash-0.0-r20150618.ebuild
@@ -8,7 +8,7 @@ inherit dotnet
DESCRIPTION="An Open Source reimplementation of Windows PowerShell"
-LICENSE="BSD || ( GPL )" # LICENSE syntax is defined in https://wiki.gentoo.org/wiki/GLEP:23
+LICENSE="BSD || ( GPL-2+ )" # LICENSE syntax is defined in https://wiki.gentoo.org/wiki/GLEP:23
SLOT="0"
@@ -25,25 +25,24 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PROJECTNAME}-${EGIT_COMMIT}"
-
METAFILETOBUILD=${PROJECTNAME}.proj
src_compile() {
- # https://bugzilla.xamarin.com/show_bug.cgi?id=9340
- if use debug; then
- exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
- else
- exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
- fi
+ # https://bugzilla.xamarin.com/show_bug.cgi?id=9340
+ if use debug; then
+ exbuild /p:DebugSymbols=True ${METAFILETOBUILD}
+ else
+ exbuild /p:DebugSymbols=False ${METAFILETOBUILD}
+ fi
}
src_install() {
- elog "Installing assemblies"
- insinto /usr/lib/pash/
- doins ${S}/Source/PashConsole/bin/Release/Pash.exe
- doins ${S}/Source/PashConsole/bin/Release/*.dll
- if use debug; then
- doins ${S}/Source/PashConsole/bin/Release/*.mdb
- fi
- make_wrapper pash "mono /usr/lib/pash/Pash.exe"
+ elog "Installing assemblies"
+ insinto /usr/lib/pash/
+ doins "${S}/Source/PashConsole/bin/Release/Pash.exe"
+ doins "${S}/Source/PashConsole/bin/Release/*.dll"
+ if use debug; then
+ doins "${S}/Source/PashConsole/bin/Release/*.mdb"
+ fi
+ make_wrapper pash "mono /usr/lib/pash/Pash.exe"
}