aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2014-10-26 19:13:24 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2014-10-26 19:13:24 -0700
commit746834ed56265ea5a99ca5975308b4d37c03584a (patch)
treec927322719ca927a41a07f2e253a449e5f293901 /x11-libs
parentupdated Adafruit kernel ebuilds with sed patch and defconfig info (diff)
downloadarm-746834ed56265ea5a99ca5975308b4d37c03584a.tar.gz
arm-746834ed56265ea5a99ca5975308b4d37c03584a.tar.bz2
arm-746834ed56265ea5a99ca5975308b4d37c03584a.zip
cleanup webkit and cairo a little
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/cairo-1.12.16.ebuild151
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-export-symbols.patch38
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-interix.patch36
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch55
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-ubuntu.patch53
-rw-r--r--x11-libs/cairo/files/cairo-1.12.10-xlib-corruption.patch90
-rw-r--r--x11-libs/cairo/files/cairo-1.12.10-xshm-corruption.patch28
-rw-r--r--x11-libs/cairo/files/cairo-1.12.12-disable-test-suite.patch12
-rw-r--r--x11-libs/cairo/files/cairo-1.12.14-libpng16.patch40
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch38
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch28
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch29
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch28
13 files changed, 0 insertions, 626 deletions
diff --git a/x11-libs/cairo/cairo-1.12.16.ebuild b/x11-libs/cairo/cairo-1.12.16.ebuild
deleted file mode 100644
index fdc6532..0000000
--- a/x11-libs/cairo/cairo-1.12.16.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit eutils flag-o-matic autotools
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
- SRC_URI=""
- KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
-else
- SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="http://cairographics.org/"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="X aqua debug directfb doc drm gallium gles2 +glib legacy-drivers opengl openvg qt4 static-libs +svg valgrind xcb xlib-xcb"
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-RDEPEND="dev-libs/lzo
- media-libs/fontconfig
- media-libs/freetype:2
- media-libs/libpng:0=
- sys-libs/zlib
- >=x11-libs/pixman-0.28.0
- directfb? ( dev-libs/DirectFB )
- gles2? ( media-libs/mesa[gles2] )
- glib? ( >=dev-libs/glib-2.28.6:2 )
- opengl? ( || ( media-libs/mesa[egl] media-libs/opengl-apple ) )
- openvg? ( media-libs/mesa[openvg] )
- qt4? ( >=dev-qt/qtgui-4.8:4 )
- X? (
- >=x11-libs/libXrender-0.6
- x11-libs/libXext
- x11-libs/libX11
- drm? (
- >=virtual/udev-136
- gallium? ( media-libs/mesa[gallium] )
- )
- )
- xcb? (
- x11-libs/libxcb
- x11-libs/xcb-util
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=sys-devel/libtool-2
- doc? (
- >=dev-util/gtk-doc-1.6
- ~app-text/docbook-xml-dtd-4.2
- )
- X? (
- x11-proto/renderproto
- drm? (
- x11-proto/xproto
- >=x11-proto/xextproto-7.1
- )
- )"
-
-# drm module requires X
-# for gallium we need to enable drm
-REQUIRED_USE="
- drm? ( X )
- gallium? ( drm )
- gles2? ( !opengl )
- openvg? ( || ( gles2 opengl ) )
- xlib-xcb? ( xcb )
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
- use legacy-drivers && epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
- epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
- epatch_user
-
- # Slightly messed build system YAY
- if [[ ${PV} == *9999* ]]; then
- touch boilerplate/Makefile.am.features
- touch src/Makefile.am.features
- touch ChangeLog
- fi
-
- # We need to run elibtoolize to ensure correct so versioning on FreeBSD
- # upgraded to an eautoreconf for the above interix patch.
- eautoreconf
-}
-
-src_configure() {
- local myopts
-
- [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
-
- use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
-
- econf \
- --disable-dependency-tracking \
- $(use_with X x) \
- $(use_enable X tee) \
- $(use_enable X xlib) \
- $(use_enable X xlib-xrender) \
- $(use_enable aqua quartz) \
- $(use_enable aqua quartz-image) \
- $(use_enable debug test-surfaces) \
- $(use_enable drm) \
- $(use_enable directfb) \
- $(use_enable gallium) \
- $(use_enable gles2 glesv2) \
- $(use_enable glib gobject) \
- $(use_enable doc gtk-doc) \
- $(use_enable openvg vg) \
- $(use_enable opengl gl) \
- $(use_enable qt4 qt) \
- $(use_enable static-libs static) \
- $(use_enable svg) \
- $(use_enable valgrind) \
- $(use_enable xcb) \
- $(use_enable xcb xcb-shm) \
- $(use_enable xlib-xcb) \
- --enable-ft \
- --enable-pdf \
- --enable-png \
- --enable-ps \
- ${myopts}
-}
-
-src_install() {
- # parallel make install fails
- emake -j1 DESTDIR="${D}" install
- find "${ED}" -name '*.la' -exec rm -f {} +
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- if use !xlib-xcb; then
- if has_version net-misc/nxserver-freenx \
- || has_version net-misc/x2goserver; then
- ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
- ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
- ewarn "applications that are running inside NX sessions. For details, see"
- ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
- fi
- fi
-}
diff --git a/x11-libs/cairo/files/cairo-1.10.2-export-symbols.patch b/x11-libs/cairo/files/cairo-1.10.2-export-symbols.patch
deleted file mode 100644
index 5f1c2d4..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-export-symbols.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Index: cairo/src/Makefile.am
-===================================================================
---- cairo.orig/src/Makefile.am 2011-02-08 10:11:46.879538772 +0100
-+++ cairo/src/Makefile.am 2011-02-08 10:12:36.381915666 +0100
-@@ -46,7 +46,7 @@
- $(enabled_cairo_private) \
- $(enabled_cairo_sources) \
- $(NULL)
--libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
-+libcairo_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols) -export-symbols-regex \^cairo_.*
- libcairo_la_LIBADD = $(CAIRO_LIBS) \
- $(cairo_cxx_lib)
- libcairo_la_DEPENDENCIES = $(cairo_def_dependency) $(cairo_cxx_lib)
-diff --git a/util/cairo-gobject/Makefile.am b/util/cairo-gobject/Makefile.am
-index 22c1a27..5a15950 100644
---- a/util/cairo-gobject/Makefile.am
-+++ b/util/cairo-gobject/Makefile.am
-@@ -10,6 +10,6 @@ libcairo_gobject_la_SOURCES = \
- $(NULL)
-
- libcairo_gobject_la_CFLAGS = $(CAIRO_CFLAGS) $(GOBJECT_CFLAGS)
--libcairo_gobject_la_LDFLAGS = -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
-+libcairo_gobject_la_LDFLAGS = -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols) -export-symbols-regex \^cairo_.*
- libcairo_gobject_la_LIBADD = $(top_builddir)/src/libcairo.la $(CAIRO_LIBS) $(GOBJECT_LIBS)
-
-diff --git a/util/cairo-script/Makefile.am b/util/cairo-script/Makefile.am
-index d7e4427..8d4181b 100644
---- a/util/cairo-script/Makefile.am
-+++ b/util/cairo-script/Makefile.am
-@@ -18,7 +18,7 @@ libcairo_script_interpreter_la_SOURCES = \
- cairo-script-stack.c \
- $(NULL)
- libcairo_script_interpreter_la_CFLAGS = $(CAIRO_CFLAGS)
--libcairo_script_interpreter_la_LDFLAGS = -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols)
-+libcairo_script_interpreter_la_LDFLAGS = -version-info $(CAIRO_LIBTOOL_VERSION_INFO) -no-undefined $(export_symbols) -export-symbols-regex \^cairo_.*
- libcairo_script_interpreter_la_LIBADD = $(top_builddir)/src/libcairo.la $(CAIRO_LIBS) -lz
-
- csi_replay_SOURCES = csi-replay.c
diff --git a/x11-libs/cairo/files/cairo-1.10.2-interix.patch b/x11-libs/cairo/files/cairo-1.10.2-interix.patch
deleted file mode 100644
index 3333e3e..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-interix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-commit 95f6f7a174ca096a3d3dbe84ff220d166d1e2baa
-Author: Uli Schlachter <psychon@znc.in>
-Date: Fri Oct 22 11:54:57 2010 +0200
-
- Make both versions of _cairo_lround consistent again
-
- Commit c0008242b0f made cairo use libm's lround instead of its own _cairo_lround
- by default. However, since commit ce58f874 from 2006, _cairo_lround does
- arithmetic rounding instead of away-from-zero rounding (before said commit, it
- was using baker's rounding).
-
- So to make the rounding of _cairo_lround be independent from
- DISABLE_SOME_FLOATING_POINT, we have to use another function. Turns out that
- _cairo_round already does the same thing that _cairo_lround does. Their only
- difference is the return type.
-
- Signed-off-by: Uli Schlachter <psychon@znc.in>
- Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
-
-diff --git a/src/cairoint.h b/src/cairoint.h
-index 53c87e5..539d92e 100644
---- a/src/cairoint.h
-+++ b/src/cairoint.h
-@@ -968,7 +968,11 @@ _cairo_round (double r)
- cairo_private int
- _cairo_lround (double d) cairo_const;
- #else
--#define _cairo_lround lround
-+static inline int cairo_const
-+_cairo_lround (double r)
-+{
-+ return _cairo_round (r);
-+}
- #endif
-
- cairo_private uint16_t
diff --git a/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch b/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch
deleted file mode 100644
index cf0b57a..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-qt-surface.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff -ruN cairo-1.10.2-0-vanilla/src/cairo-qt-surface.cpp cairo-1.10.2/src/cairo-qt-surface.cpp
---- cairo-1.10.2-0-vanilla/src/cairo-qt-surface.cpp 2010-12-25 15:21:34.000000000 +0100
-+++ cairo-1.10.2/src/cairo-qt-surface.cpp 2011-12-20 22:59:30.000000000 +0100
-@@ -61,7 +61,9 @@
- #include <QtGui/QX11Info>
- #include <QtCore/QVarLengthArray>
-
--#if (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
-+#if (QT_VERSION >= QT_VERSION_CHECK(4, 8, 0))
-+#include <QtGui/QGlyphRun>
-+#elif (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
- extern void qt_draw_glyphs(QPainter *, const quint32 *glyphs, const QPointF *positions, int count);
- #endif
-
-@@ -1370,7 +1372,39 @@
- cairo_clip_t *clip,
- int *remaining_glyphs)
- {
--#if (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
-+#if (QT_VERSION >= QT_VERSION_CHECK(4, 8, 0)) && !defined(QT_NO_RAWFONT)
-+ cairo_qt_surface_t *qs = (cairo_qt_surface_t *) abstract_surface;
-+
-+ // pick out the colour to use from the cairo source
-+ cairo_solid_pattern_t *solid = (cairo_solid_pattern_t*) source;
-+ // documentation says you have to freeze the cache, but I don't believe it
-+ _cairo_scaled_font_freeze_cache(scaled_font);
-+
-+ QColor tempColour(solid->color.red * 255, solid->color.green * 255, solid->color.blue * 255);
-+ QVector<QPointF> positions(num_glyphs);
-+ QVector<unsigned int> glyphss(num_glyphs);
-+ FT_Face face = cairo_ft_scaled_font_lock_face (scaled_font);
-+ const FT_Size_Metrics& ftMetrics = face->size->metrics;
-+ QFont font(face->family_name);
-+ font.setStyleStrategy(QFont::NoFontMerging);
-+ font.setBold(face->style_flags & FT_STYLE_FLAG_BOLD);
-+ font.setItalic(face->style_flags & FT_STYLE_FLAG_ITALIC);
-+ font.setKerning(face->face_flags & FT_FACE_FLAG_KERNING);
-+ font.setPixelSize(ftMetrics.y_ppem);
-+ cairo_ft_scaled_font_unlock_face(scaled_font);
-+ qs->p->setFont(font);
-+ qs->p->setPen(tempColour);
-+ for (int currentGlyph = 0; currentGlyph < num_glyphs; currentGlyph++) {
-+ positions.append(QPointF(glyphs[currentGlyph].x, glyphs[currentGlyph].y));
-+ glyphss.append(glyphs[currentGlyph].index);
-+ }
-+ QGlyphRun qglyphs;
-+ qglyphs.setGlyphIndexes(glyphss);
-+ qglyphs.setPositions(positions);
-+ qs->p->drawGlyphRun(QPointF(), qglyphs);
-+ _cairo_scaled_font_thaw_cache(scaled_font);
-+ return CAIRO_INT_STATUS_SUCCESS;
-+#elif (QT_VERSION >= QT_VERSION_CHECK(4, 7, 0)) || defined(QT_GLYPHS_API_BACKPORT)
- cairo_qt_surface_t *qs = (cairo_qt_surface_t *) abstract_surface;
-
- // pick out the colour to use from the cairo source
diff --git a/x11-libs/cairo/files/cairo-1.10.2-ubuntu.patch b/x11-libs/cairo/files/cairo-1.10.2-ubuntu.patch
deleted file mode 100644
index 751bbd4..0000000
--- a/x11-libs/cairo/files/cairo-1.10.2-ubuntu.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- cairo.orig/build/configure.ac.features 2010-12-28 14:41:21.487225155 +0100
-+++ cairo/build/configure.ac.features 2010-12-28 14:42:06.166239606 +0100
-@@ -407,6 +407,7 @@
- echo "The following features and utilities:"
- echo " cairo-trace: $use_trace"
- echo " cairo-script-interpreter: $use_interpreter"
-+ echo " cairo-perf-utils: $use_perf_utils"
- echo ""
- echo "And the following internal features:"
- echo " pthread: $use_pthread"
---- cairo.orig/configure.ac 2010-12-28 14:43:02.291226995 +0100
-+++ cairo/configure.ac 2010-12-28 14:43:18.191141863 +0100
-@@ -10,6 +10,7 @@
- AC_CONFIG_SRCDIR(src/cairo.h)
- AC_CONFIG_HEADERS(config.h)
- AM_INIT_AUTOMAKE([1.9.6 gnu -Wall no-define])
-+AM_MAINTAINER_MODE
- m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
- AC_LIBTOOL_WIN32_DLL dnl Must be called before AC_PROG_LIBTOOL
- AC_PROG_LIBTOOL dnl ([1.4]) Don't remove!
-@@ -796,6 +796,11 @@
- PKG_CHECK_MODULES(gtk, "gtk+-2.0",have_gtk=yes, have_gtk=no)
- AM_CONDITIONAL(HAVE_GTK, test "x$have_gtk" = "xyes")
-
-+dnl ===========================================================================
-+
-+CAIRO_ENABLE(perf_utils, cairo-perf-utils, no, [use_perf_utils=yes])
-+
-+
- AC_CONFIG_FILES([
- Makefile
- boilerplate/Makefile
---- cairo.orig/perf/Makefile.am 2010-06-18 13:47:11.000000000 +0200
-+++ cairo/perf/Makefile.am 2010-12-28 14:42:06.162226875 +0100
-@@ -10,6 +10,18 @@
-
- AM_LDFLAGS = $(CAIRO_LDFLAGS)
-
-+if CAIRO_HAS_PERF_UTILS
-+bin_PROGRAMS = cairo-perf-micro \
-+ cairo-perf-trace \
-+ cairo-perf-diff-files \
-+ cairo-perf-print \
-+ cairo-perf-chart \
-+ cairo-perf-compare-backends
-+if HAVE_GTK
-+bin_PROGRAMS += cairo-perf-graph-files
-+endif
-+endif
-+
- EXTRA_PROGRAMS += cairo-perf-micro \
- cairo-perf-trace \
- cairo-perf-diff-files \
diff --git a/x11-libs/cairo/files/cairo-1.12.10-xlib-corruption.patch b/x11-libs/cairo/files/cairo-1.12.10-xlib-corruption.patch
deleted file mode 100644
index 84bab57..0000000
--- a/x11-libs/cairo/files/cairo-1.12.10-xlib-corruption.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From fa4f48cccb6c7f4e1afb2ff4b98b906b7d8d4afc Mon Sep 17 00:00:00 2001
-From: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Wed, 23 Jan 2013 15:04:26 +0000
-Subject: xlib: Do not upload the whole image just because we want an entire row
-
-Fixes regression exposed by
-
-commit a73e7ff0186176bc82cd3ae1432c054c1fd3aebd
-Author: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Sun Jan 6 11:29:27 2013 +0000
-
- xlib: Simplify source creation by use of map-to-image
-
-but ultimately from
-
-commit 74941f822015cc50cd8477d0cf97f1a70dbff60b
-Author: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Wed Jan 2 22:27:55 2013 +0000
-
- xlib: Use SHM transport for ordinary image uploads
-
-Reported-by: Gökçen Eraslan <gokcen.eraslan@gmail.com>
-Reported-by: Guillaume Ayoub <guillaume.ayoub@kozea.fr>
-Reported-by: Emmanuel Benisty <benisty.e@gmail.com>
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=59635
-Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
----
-diff --git a/src/cairo-xlib-source.c b/src/cairo-xlib-source.c
-index 24290f7..ca55278 100644
---- a/src/cairo-xlib-source.c
-+++ b/src/cairo-xlib-source.c
-@@ -1035,7 +1035,13 @@ surface_source (cairo_xlib_surface_t *dst,
-
- status = _cairo_surface_unmap_image (&xsrc->base, image);
- if (unlikely (status)) {
-- cairo_surface_destroy (src);
-+ cairo_surface_destroy (&xsrc->base);
-+ return _cairo_surface_create_in_error (status);
-+ }
-+
-+ status = _cairo_xlib_surface_put_shm (xsrc);
-+ if (unlikely (status)) {
-+ cairo_surface_destroy (&xsrc->base);
- return _cairo_surface_create_in_error (status);
- }
- }
-diff --git a/src/cairo-xlib-surface.c b/src/cairo-xlib-surface.c
-index dbc677e..ee69b66 100644
---- a/src/cairo-xlib-surface.c
-+++ b/src/cairo-xlib-surface.c
-@@ -1139,26 +1139,24 @@ _cairo_xlib_surface_draw_image (cairo_xlib_surface_t *surface,
- max_request_size = XMaxRequestSize (display->display);
- if (max_request_size > 8192)
- max_request_size = 8192;
-- if (image->stride * image->height > max_request_size) {
-+ if (width * height * 4 > max_request_size) {
- shm_image = _cairo_xlib_surface_create_shm__image (surface,
- image->pixman_format,
-- image->width,
-- image->height);
-+ width, height);
- if (shm_image && shm_image->status == CAIRO_STATUS_SUCCESS) {
- cairo_image_surface_t *clone = (cairo_image_surface_t *) shm_image;
-- if (clone->stride == image->stride) {
-- memcpy (clone->data, image->data, clone->stride * clone->height);
-- } else {
-- pixman_image_composite32 (PIXMAN_OP_SRC,
-- image->pixman_image, NULL, clone->pixman_image,
-- 0, 0,
-- 0, 0,
-- 0, 0,
-- image->width, image->height);
-- }
-+ pixman_image_composite32 (PIXMAN_OP_SRC,
-+ image->pixman_image, NULL, clone->pixman_image,
-+ src_x, src_y,
-+ 0, 0,
-+ 0, 0,
-+ width, height);
- ximage.obdata = _cairo_xlib_shm_surface_get_obdata (shm_image);
- ximage.data = (char *)clone->data;
- ximage.bytes_per_line = clone->stride;
-+ ximage.width = width;
-+ ximage.height = height;
-+ src_x = src_y = 0;
- }
- }
- } else
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.10-xshm-corruption.patch b/x11-libs/cairo/files/cairo-1.12.10-xshm-corruption.patch
deleted file mode 100644
index 92bf134..0000000
--- a/x11-libs/cairo/files/cairo-1.12.10-xshm-corruption.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From c006b886d28a772d7a62cec52ab7e0c8196c36f6 Mon Sep 17 00:00:00 2001
-From: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Tue, 29 Jan 2013 03:01:31 +0000
-Subject: xlib/shm: Force synchronisation for scratch SHM image buffers
-
-The scratch image buffers are used for uploads to the xserver and so we
-must be careful not to overwrite active SHM segments. Unfortunately we
-told the core SHM allocator that we would sync before using the images,
-which was a lie.
-
-Reported-by: Michael Natterer <mitch@gimp.org>
-Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
----
-diff --git a/src/cairo-xlib-surface-shm.c b/src/cairo-xlib-surface-shm.c
-index 43cecdf..32c7033 100644
---- a/src/cairo-xlib-surface-shm.c
-+++ b/src/cairo-xlib-surface-shm.c
-@@ -1155,7 +1155,7 @@ _cairo_xlib_surface_create_shm__image (cairo_xlib_surface_t *surface,
- return NULL;
-
- return &_cairo_xlib_shm_surface_create (surface, format, width, height,
-- TRUE, 0)->image.base;
-+ FALSE, 0)->image.base;
- }
-
- cairo_surface_t *
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.12-disable-test-suite.patch b/x11-libs/cairo/files/cairo-1.12.12-disable-test-suite.patch
deleted file mode 100644
index 37033d7..0000000
--- a/x11-libs/cairo/files/cairo-1.12.12-disable-test-suite.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN cairo-1.12.10.orig/test/Makefile.am cairo-1.12.10/test/Makefile.am
---- cairo-1.12.10.orig/test/Makefile.am 2013-01-27 14:56:03.345178612 -0800
-+++ cairo-1.12.10/test/Makefile.am 2013-01-27 14:56:15.371177856 -0800
-@@ -71,8 +71,6 @@
- endif
- test_sources += $(test)
-
--noinst_PROGRAMS = cairo-test-suite$(EXEEXT) # always build
--
- TESTS += cairo-test-suite$(EXEEXT)
-
- cairo-test-constructors.c: Makefile $(test_sources) make-cairo-test-constructors.sh
diff --git a/x11-libs/cairo/files/cairo-1.12.14-libpng16.patch b/x11-libs/cairo/files/cairo-1.12.14-libpng16.patch
deleted file mode 100644
index c163178..0000000
--- a/x11-libs/cairo/files/cairo-1.12.14-libpng16.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 2dd2c826a5b367d32cf2d48ed69754795990c5db Mon Sep 17 00:00:00 2001
-From: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Tue, 16 Apr 2013 09:58:56 +0000
-Subject: png: Avoid marking the surface as in error after a png warning
-
-It turns out that libpng will continue to load an image after throwing a
-warning, and that libpng16 now throws warnings for images that libpng15
-and earlier loaded without error. As we were happily loading those
-images into cairo surfaces before, we are therefore being overzealous
-in throwing an error now - so just squelch the warning.
-
-Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
----
-diff --git a/src/cairo-png.c b/src/cairo-png.c
-index e74a4a8..068617d 100644
---- a/src/cairo-png.c
-+++ b/src/cairo-png.c
-@@ -149,13 +149,13 @@ static void
- png_simple_warning_callback (png_structp png,
- png_const_charp error_msg)
- {
-- cairo_status_t *error = png_get_error_ptr (png);
--
-- /* default to the most likely error */
-- if (*error == CAIRO_STATUS_SUCCESS)
-- *error = _cairo_error (CAIRO_STATUS_NO_MEMORY);
--
-- /* png does not expect to abort and will try to tidy up after a warning */
-+ /* png does not expect to abort and will try to tidy up and continue
-+ * loading the image after a warning. So we also want to return the
-+ * (incorrect?) surface.
-+ *
-+ * We use our own warning callback to squelch any attempts by libpng
-+ * to write to stderr as we may not be in control of that output.
-+ */
- }
-
-
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch
deleted file mode 100644
index cef9e29..0000000
--- a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 3b261bea7d8e8094ff3899aefab6bbc8628a3585 Mon Sep 17 00:00:00 2001
-From: Chris Wilson <chris@chris-wilson.co.uk>
-Date: Thu, 06 Mar 2014 08:34:10 +0000
-Subject: clip: Do not modify the special all-clipped cairo_clip_t
-
-Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75819
----
-diff --git a/src/cairo-clip-boxes.c b/src/cairo-clip-boxes.c
-index bbb4197..352654f 100644
---- a/src/cairo-clip-boxes.c
-+++ b/src/cairo-clip-boxes.c
-@@ -173,7 +173,7 @@ _cairo_clip_intersect_rectangle_box (cairo_clip_t *clip,
- clip->extents = *r;
- } else {
- if (! _cairo_rectangle_intersect (&clip->extents, r))
-- clip = _cairo_clip_set_all_clipped (clip);
-+ return _cairo_clip_set_all_clipped (clip);
- }
- if (clip->path == NULL)
- clip->is_region = _cairo_box_is_pixel_aligned (box);
-@@ -312,10 +312,12 @@ _cairo_clip_intersect_boxes (cairo_clip_t *clip,
- _cairo_boxes_extents (boxes, &limits);
-
- _cairo_box_round_to_rectangle (&limits, &extents);
-- if (clip->path == NULL)
-+ if (clip->path == NULL) {
- clip->extents = extents;
-- else if (! _cairo_rectangle_intersect (&clip->extents, &extents))
-+ } else if (! _cairo_rectangle_intersect (&clip->extents, &extents)) {
- clip = _cairo_clip_set_all_clipped (clip);
-+ goto out;
-+ }
-
- if (clip->region) {
- cairo_region_destroy (clip->region);
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch
deleted file mode 100644
index df537da..0000000
--- a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ed175b2a2bebb6def85133257bc11a875d13b0dd Mon Sep 17 00:00:00 2001
-From: Uli Schlachter <psychon@znc.in>
-Date: Thu, 06 Mar 2014 08:45:08 +0000
-Subject: clip: Fix handling of special all-clipped cairo_clip_t
-
-_cairo_clip_intersect_box() wasn't checking if it was called with the special,
-read-only all-clipped clip and thus could have ended up writing to read-only
-memory.
-
-References: https://bugs.freedesktop.org/show_bug.cgi?id=75819
-Signed-off-by: Uli Schlachter <psychon@znc.in>
----
-diff --git a/src/cairo-clip-boxes.c b/src/cairo-clip-boxes.c
-index 352654f..7bcbeb1 100644
---- a/src/cairo-clip-boxes.c
-+++ b/src/cairo-clip-boxes.c
-@@ -258,6 +258,9 @@ _cairo_clip_intersect_box (cairo_clip_t *clip,
- {
- cairo_rectangle_int_t r;
-
-+ if (_cairo_clip_is_all_clipped (clip))
-+ return clip;
-+
- _cairo_box_round_to_rectangle (box, &r);
- if (r.width == 0 || r.height == 0)
- return _cairo_clip_set_all_clipped (clip);
---
-cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch
deleted file mode 100644
index 8b796fa..0000000
--- a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 18b3cce2f5812c357e4b6310e72d72dd9ec92ed4 Mon Sep 17 00:00:00 2001
-From: Bryce Harrington <b.harrington@samsung.com>
-Date: Tue, 6 May 2014 10:18:19 -0700
-Subject: [PATCH] Fix segfault in firefox when scrolling on certain pages
-
-Bug discovered by thorsten <fly_a320@gmx.de>
-
-Patch from Chris Wilson <chris@chris-wilson.co.uk>
----
- src/cairo-xcb-surface-render.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/cairo-xcb-surface-render.c b/src/cairo-xcb-surface-render.c
-index 9625953..75455e5 100644
---- a/src/cairo-xcb-surface-render.c
-+++ b/src/cairo-xcb-surface-render.c
-@@ -3121,6 +3121,9 @@ _clip_and_composite_boxes (cairo_xcb_surface_t *dst,
-
- clip = _cairo_clip_copy (extents->clip);
- clip = _cairo_clip_intersect_boxes (clip, boxes);
-+ if (_cairo_clip_is_all_clipped (clip))
-+ return CAIRO_INT_STATUS_NOTHING_TO_DO;
-+
- status = _cairo_clip_get_polygon (clip, &polygon,
- &fill_rule, &antialias);
- _cairo_clip_path_destroy (clip->path);
---
-1.9.2
-
diff --git a/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch b/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch
deleted file mode 100644
index 641ccea..0000000
--- a/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/build/configure.ac.warnings b/build/configure.ac.warnings
-index f984eb2..15b3da2 100644
---- a/build/configure.ac.warnings
-+++ b/build/configure.ac.warnings
-@@ -38,13 +38,18 @@ dnl options. Namely, the following:
-
- dnl -flto working really needs a test link, not just a compile
-
--safe_MAYBE_WARN="$MAYBE_WARN"
--MAYBE_WARN="$MAYBE_WARN -flto"
--AC_TRY_LINK([],[
-+AC_ARG_ENABLE(lto,
-+ AS_HELP_STRING([--disable-lto],
-+ [Do not try to use Link-Time Optimization]))
-+if test "x$enable_lto" != "xno"; then
-+ safe_MAYBE_WARN="$MAYBE_WARN"
-+ MAYBE_WARN="$MAYBE_WARN -flto"
-+ AC_TRY_LINK([],[
- int main(int argc, char **argv) { return 0; }
--],[],[
-+ ],[],[
- MAYBE_WARN="$safe_MAYBE_WARN"
--])
-+ ])
-+fi
-
- MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
-