aboutsummaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:41:44 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-05-14 00:41:44 -0700
commit4ba627f63bf27fa51026ba1bd2b25025a9c983ef (patch)
treef25e1f62b921bb01f3268f102dde759c16f46da7 /dev-db
parentadjust for hardfloat without neon (tested on rpi) (diff)
downloadarm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.tar.gz
arm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.tar.bz2
arm-4ba627f63bf27fa51026ba1bd2b25025a9c983ef.zip
major cruft removal
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/files/maketcllib.sh40
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch12
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch12
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch49
4 files changed, 0 insertions, 113 deletions
diff --git a/dev-db/sqlite/files/maketcllib.sh b/dev-db/sqlite/files/maketcllib.sh
deleted file mode 100644
index ad87ce1..0000000
--- a/dev-db/sqlite/files/maketcllib.sh
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/bash
-#
-# This script was adapted from the one used by Hwaci to build it's
-# documentation and binaries for shipping to their website.
-#
-# Any similarity to the original has probably been trampled into
-# oblivion modifying everything for Gentoo.
-#
-echo "Starting TCL Build"
-
-# Set srcdir to the name of the directory that contains the publish.sh
-# script.
-#
-srcdir=`echo "$0" | sed 's%\(^.*\)/[^/][^/]*$%\1%'`
-
-#
-# Build the tclsqlite.so shared library for import into tclsh or wish
-# under Linux
-#
-make target_source
-source /etc/make.conf
-cd tsrc
-rm shell.c
-
-OPTS='-DUSE_TCL_STUBS=1 -DNDEBUG=1'
-TCLSTUBLIB=${TCL_BUILD_STUB_LIB_PATH}
-
-export CFLAGS
-gcc -fPIC $CFLAGS $OPTS -I. -shared *.c $TCLSTUBLIB -o tclsqlite.so
-
-strip tclsqlite.so
-cp tclsqlite.so ..
-
-cd ..
-
-echo "pkg_mkIndex [pwd] tclsqlite.so" >> make_pkgIndex.tcl
-tclsh make_pkgIndex.tcl
-
-echo "Done TCL Build"
-
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch b/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch
deleted file mode 100644
index bd55a07..0000000
--- a/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac
-+++ configure.ac
-@@ -70,6 +70,9 @@
- [], [enable_dynamic_extensions=yes])
- if test x"$enable_dynamic_extensions" != "xno"; then
- AC_SEARCH_LIBS(dlopen, dl)
-+ if test "${ac_cv_search_dlopen}" = "no" ; then
-+ DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
-+ fi
- else
- DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
- fi
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch b/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch
deleted file mode 100644
index 0c5b48d..0000000
--- a/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac
-+++ configure.ac
-@@ -611,6 +611,9 @@
- if test "${use_loadextension}" = "yes" ; then
- OPT_FEATURE_FLAGS=""
- AC_SEARCH_LIBS(dlopen, dl)
-+ if test "${ac_cv_search_dlopen}" = "no" ; then
-+ OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
-+ fi
- else
- OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
- fi
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch b/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch
deleted file mode 100644
index c6cbb33..0000000
--- a/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- test/fts4unicode.test
-+++ test/fts4unicode.test
-@@ -366,27 +366,26 @@
- do_isspace_test 6.$T.1 $T 32
- do_isspace_test 6.$T.2 $T 160
- do_isspace_test 6.$T.3 $T 5760
-- do_isspace_test 6.$T.4 $T 6158
-- do_isspace_test 6.$T.5 $T 8192
-- do_isspace_test 6.$T.6 $T 8193
-- do_isspace_test 6.$T.7 $T 8194
-- do_isspace_test 6.$T.8 $T 8195
-- do_isspace_test 6.$T.9 $T 8196
-- do_isspace_test 6.$T.10 $T 8197
-- do_isspace_test 6.$T.11 $T 8198
-- do_isspace_test 6.$T.12 $T 8199
-- do_isspace_test 6.$T.13 $T 8200
-- do_isspace_test 6.$T.14 $T 8201
-- do_isspace_test 6.$T.15 $T 8202
-- do_isspace_test 6.$T.16 $T 8239
-- do_isspace_test 6.$T.17 $T 8287
-- do_isspace_test 6.$T.18 $T 12288
-+ do_isspace_test 6.$T.4 $T 8192
-+ do_isspace_test 6.$T.5 $T 8193
-+ do_isspace_test 6.$T.6 $T 8194
-+ do_isspace_test 6.$T.7 $T 8195
-+ do_isspace_test 6.$T.8 $T 8196
-+ do_isspace_test 6.$T.9 $T 8197
-+ do_isspace_test 6.$T.10 $T 8198
-+ do_isspace_test 6.$T.11 $T 8199
-+ do_isspace_test 6.$T.12 $T 8200
-+ do_isspace_test 6.$T.13 $T 8201
-+ do_isspace_test 6.$T.14 $T 8202
-+ do_isspace_test 6.$T.15 $T 8239
-+ do_isspace_test 6.$T.16 $T 8287
-+ do_isspace_test 6.$T.17 $T 12288
-
-- do_isspace_test 6.$T.19 $T {32 160 5760 6158}
-- do_isspace_test 6.$T.20 $T {8192 8193 8194 8195}
-- do_isspace_test 6.$T.21 $T {8196 8197 8198 8199}
-- do_isspace_test 6.$T.22 $T {8200 8201 8202 8239}
-- do_isspace_test 6.$T.23 $T {8287 12288}
-+ do_isspace_test 6.$T.18 $T {32 160 5760}
-+ do_isspace_test 6.$T.19 $T {8192 8193 8194 8195}
-+ do_isspace_test 6.$T.20 $T {8196 8197 8198 8199}
-+ do_isspace_test 6.$T.21 $T {8200 8201 8202 8239}
-+ do_isspace_test 6.$T.22 $T {8287 12288}
- }
-
- #-------------------------------------------------------------------------