summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/google-talkplugin/google-talkplugin-9999.ebuild')
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild b/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
index 729af912b39d..75d88e264f7d 100644
--- a/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
+++ b/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild,v 1.22 2014/11/02 10:30:09 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild,v 1.23 2014/11/08 20:22:26 ottxor Exp $
EAPI=5
@@ -13,6 +13,7 @@ if [ "${PV}" != "9999" ]; then
MY_PKG="${PN}_${PV}-${DEB_PATCH}_i386.deb"
SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
+ KEYWORDS="-* ~amd64 ~x86"
else
inherit cvs #hack to make it part of @live-rebuild
MY_URL="http://dl.google.com/linux/direct"
@@ -26,7 +27,6 @@ HOMEPAGE="http://www.google.com/chat/video"
IUSE="libnotify selinux"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
#GoogleTalkPlugin binary contains openssl and celt
LICENSE="Google-TOS openssl BSD"
@@ -34,13 +34,17 @@ OBSOLETE="no"
[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
+ dev-libs/expat
dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
sys-libs/glibc
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:2
x11-libs/libX11
x11-libs/libXcomposite
+ x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXrandr
x11-libs/libXrender