summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-2.00.ebuild')
-rw-r--r--sys-boot/grub/grub-2.00.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-boot/grub/grub-2.00.ebuild b/sys-boot/grub/grub-2.00.ebuild
index 4be1e7ce7305..9f571cbda9b6 100644
--- a/sys-boot/grub/grub-2.00.ebuild
+++ b/sys-boot/grub/grub-2.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.12 2012/07/07 22:55:48 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00.ebuild,v 1.13 2012/07/13 18:05:19 floppym Exp $
EAPI=4
@@ -22,7 +22,7 @@ else
DO_AUTORECONF="true"
fi
-inherit eutils flag-o-matic pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
+inherit eutils flag-o-matic multiprocessing pax-utils toolchain-funcs ${DO_AUTORECONF:+autotools} ${LIVE_ECLASS}
unset LIVE_ECLASS
DESCRIPTION="GNU GRUB boot loader"
@@ -253,9 +253,11 @@ src_configure() {
# Sandbox bug 404013.
use libzfs && addpredict /etc/dfs:/dev/zfs
+ multijob_init
for i in ${GRUB_ENABLED_PLATFORMS}; do
- grub_run_phase ${FUNCNAME} ${i}
+ multijob_child_init grub_run_phase ${FUNCNAME} ${i}
done
+ multijob_finish || die
}
src_compile() {