summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/shadow/shadow-4.0.3-r3.ebuild')
-rw-r--r--sys-apps/shadow/shadow-4.0.3-r3.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-apps/shadow/shadow-4.0.3-r3.ebuild b/sys-apps/shadow/shadow-4.0.3-r3.ebuild
index dc9b1362bd78..12c5b44d327d 100644
--- a/sys-apps/shadow/shadow-4.0.3-r3.ebuild
+++ b/sys-apps/shadow/shadow-4.0.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3-r3.ebuild,v 1.10 2003/06/21 21:19:40 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.3-r3.ebuild,v 1.11 2003/09/07 00:44:11 msterret Exp $
IUSE="selinux"
@@ -22,7 +22,7 @@ DEPEND=">=sys-libs/pam-0.75-r4
>=sys-libs/cracklib-2.7-r3
sys-devel/gettext
selinux? ( sys-apps/selinux-small )"
-
+
RDEPEND=">=sys-libs/pam-0.75-r4
>=sys-libs/cracklib-2.7-r3"
@@ -33,7 +33,7 @@ pkg_preinst() {
src_unpack() {
unpack ${A}
-
+
cd ${S}
# Get su to call pam_open_session(), and also set DISPLAY and XAUTHORITY,
# else the session entries in /etc/pam.d/su never get executed, and
@@ -65,7 +65,7 @@ src_compile() {
--enable-static=yes \
--host=${CHOST} \
${myconf} || die "bad configure"
-
+
# Parallel make fails sometimes
make || die "compile problem"
}
@@ -122,7 +122,7 @@ src_install() {
newins shadow chfn
newins shadow useradd
newins shadow groupadd
-
+
cd ${S}
# The manpage install is beyond my comprehension, and
# also broken. Just do it over.
@@ -131,14 +131,14 @@ src_install() {
do
[ -f ${x} ] && doman ${x}
done
-
+
# Dont install the manpage, since we dont use
# login with shadow
# (selinux does, so we install the man pages in that case)
use selinux || rm -f ${D}/usr/share/man/man1/login.*
# We use pam, so this is not applicable.
rm -f ${D}/usr/share/man/man5/suauth.*
-
+
cd ${S}/doc
dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
docinto txt
@@ -165,7 +165,7 @@ pkg_postinst() {
ewarn
ewarn " ${ROOT}etc/pam.d/system-auth.bak"
echo
-
+
cp -a ${ROOT}/etc/pam.d/system-auth \
${ROOT}/etc/pam.d/system-auth.bak;
mv -f ${ROOT}/etc/pam.d/system-auth.new \