summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild')
-rw-r--r--sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild102
1 files changed, 0 insertions, 102 deletions
diff --git a/sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild b/sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild
deleted file mode 100644
index eb5025ba4666..000000000000
--- a/sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Tony Murray <murrant@bvu.edu>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/module-init-tools/module-init-tools-0.9.1.ebuild,v 1.2 2002/12/11 08:11:35 lostlogic Exp $
-
-# This includes backwards compatability for stable kernels
-
-S="${WORKDIR}/${P}"
-MODUTILS_PV=2.4.22
-DESCRIPTION="Kernel module tools for the development kernel >=2.5.48"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/people/rusty/modules/${P}.tar.bz2
- http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.4/modutils-${MODUTILS_PV}.tar.bz2"
-HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/rusty/modules"
-KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
-LICENSE="GPL-2"
-SLOT="0"
-
-DEPEND="virtual/glibc"
-RDEPEND=">=development-sources-2.5.48"
-
-src_compile() {
- einfo "Building modutils..."
- cd ${WORKDIR}/modutils-${MODUTILS_PV}
-
- econf \
- --disable-strip \
- --prefix=/ \
- --enable-insmod-static \
- --disable-zlib \
- ${myconf}
- emake || die "emake modultils failed"
-
- einfo "Building module-init-tools..."
- cd ${S}
-
- econf \
- --host=${CHOST} \
- --prefix=/ \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man
- emake || die "emake module-init-tools failed"
-}
-
-src_install () {
-
- cd ${WORKDIR}/modutils-${MODUTILS_PV}
- einstall prefix="${D}"
- dodoc COPYING CREDITS ChangeLog NEWS README TODO
- cd ${S}
-
- #this copies the old version of modutils to *.old so it still works
- #with kernels <= 2.4
- #This code was borrowed from the module-init-tools Makefile
- for f in lsmod modprobe rmmod depmod insmod; do
- if [ -L ${D}/sbin/${f} ]; then
- ln -sf `ls -l ${D}/sbin/${f} | \
- sed 's/.* -> //'`.old ${D}/sbin/${f};
- fi;
- mv ${D}/sbin/${f} ${D}/sbin/${f}.old;
- done
-# make prefix=${D} move-old-targets || die "Renaming old bins to *.old failed"
-
- einstall \
- prefix=${D} \
- mandir=${D}/usr/share/man
- #create the new modprobe.conf
- dodir /etc
- ${S}/modules.conf2modprobe.conf /etc/modules.conf ${D}/etc/modprobe.conf || die "Could not create modprobe.conf"
- dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
-
- #Notify user of crap, hope for a better way ;-)
- einfo "This overwrites the modutils files, so if you remove this,"
- einfo "remember to remerge modutils. However, this package has"
- einfo "installed a copy of the modutils files with suffix .old"
- einfo "in your /sbin directory."
-}
-
-#pkg_prerm() {
-# for f in lsmod modprobe rmmod depmod insmod; do
-# if [ -L /sbin/${f}.old ]; then
-# ln -sf `ls -l /sbin/${f}.old | \
-# sed 's/.* -> \(.*\)\.old/\1/'` /sbin/${f};
-# fi;
-# mv /sbin/${f}.old /sbin/${f};
-# done
-#}
-
-pkg_postrm() {
-# ewarn "Uninstalling this package has switched you to"
-# ewarn "a modutils installtion which is not managed"
-# ewarn "by the portage system. Your system should"
-# ewarn "function acceptably on the 2.4 or lower kernels"
-# ewarn "just as it is, but we do recommend remerging"
-# ewarn "modutils."
- if [ "$(best_version ${PN})" == "${CATEGORY}/${PF}" -a ! -f /sbin/insmod ]; then
- ewarn "Uninstalling module-init-tools has left you"
- ewarn "without a modutils installtion. we recommend"
- ewarn "emerging modutils immediately or remerging"
- ewarn "module-init-tools."
- fi
-}
-