summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/help2man/help2man-1.35.1.ebuild')
-rw-r--r--sys-apps/help2man/help2man-1.35.1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-apps/help2man/help2man-1.35.1.ebuild b/sys-apps/help2man/help2man-1.35.1.ebuild
index 4469e7d306fd..2eaabb6f7f25 100644
--- a/sys-apps/help2man/help2man-1.35.1.ebuild
+++ b/sys-apps/help2man/help2man-1.35.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.35.1.ebuild,v 1.5 2005/09/16 08:03:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.35.1.ebuild,v 1.6 2006/05/08 03:57:44 flameeyes Exp $
DESCRIPTION="GNU utility to convert program --help output to a man page"
HOMEPAGE="http://www.gnu.org/software/help2man"
@@ -8,16 +8,20 @@ SRC_URI="http://ftp.gnu.org/gnu/help2man/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="nls"
RDEPEND="dev-lang/perl"
DEPEND="${RDEPEND}
- nls? ( dev-perl/Locale-gettext
- >=sys-devel/gettext-0.12.1-r1 )"
+ elibc_glibc? ( nls? ( dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1 ) )"
src_compile() {
- econf $(use_enable nls) || die
+ local myconf
+ use elibc_glibc && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
emake || die "emake failed"
}