summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild')
-rw-r--r--sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
index d11cccf37f2e..940b7628236a 100644
--- a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
+++ b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild,v 1.1 2014/01/14 21:47:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild,v 1.2 2014/01/15 18:20:43 bicatali Exp $
EAPI=5
@@ -12,7 +12,7 @@ DESCRIPTION="COIN-OR Branch-Cut-Price Framework"
HOMEPAGE="https://projects.coin-or.org/Bcp/"
SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-LICENSE="EPL-1.0"
+LICENSE="CPL-1.0"
SLOT="0/1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs test"
@@ -27,23 +27,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-src_prepare() {
- # as-needed fix
- # hack to avoid eautoreconf (coinor has its own weird autotools)
- sed -i \
- -e 's:\(libBcp_la_LIBADD.*=\).*:\1 @BCPLIB_LIBS@:g' \
- src/Makefile.in || die
-}
-
src_configure() {
- PKG_CONFIG_PATH+="${ED}"/usr/$(get_libdir)/pkgconfig \
- autotools-utils_src_configure
+ local myeconfargs=(
+ --enable-dependency-linking
+ )
+ autotools-utils_src_configure
}
src_test() {
- pushd "${BUILD_DIR}" > /dev/null || die
- emake test
- popd > /dev/null || die
+ autotools-utils_src_test test
}
src_install() {