summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/kicad/kicad-20070525.ebuild')
-rw-r--r--sci-electronics/kicad/kicad-20070525.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-electronics/kicad/kicad-20070525.ebuild b/sci-electronics/kicad/kicad-20070525.ebuild
index 1a6cdf552853..a7cb7ef1af22 100644
--- a/sci-electronics/kicad/kicad-20070525.ebuild
+++ b/sci-electronics/kicad/kicad-20070525.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.3 2007/06/23 20:12:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-20070525.ebuild,v 1.4 2007/07/07 08:44:26 calchan Exp $
inherit wxwidgets
@@ -15,11 +15,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="doc examples minimal unicode"
-DEPEND=">=x11-libs/wxGTK-2.6"
+DEPEND="=x11-libs/wxGTK-2.6*"
pkg_setup() {
- # Tell wxwidgets.eclass the version we need. We pick the latest on the system.
- WX_GTK_VER=$(`ls /usr/bin/wx-config* | sort | tail -n 1` --release)
+ # Tell wxwidgets.eclass which version we need
+ WX_GTK_VER="2.6"
# Check for proper wxGTK USE flags.
if use unicode; then
@@ -27,7 +27,7 @@ pkg_setup() {
else
need-wxwidgets gtk2 || die "You need to install wxGTK with gtk2 support."
fi
- built_with_use ">=x11-libs/wxGTK-${WX_GTK_VER}" opengl || die "You need to install wxGTK with opengl support."
+ built_with_use "=x11-libs/wxGTK-${WX_GTK_VER}*" opengl || die "You need to install wxGTK with opengl support."
}
src_unpack() {