summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild')
-rw-r--r--sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild27
1 files changed, 7 insertions, 20 deletions
diff --git a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
index 8a3cab5dc26b..9c5c04dc6ae9 100644
--- a/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
+++ b/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild,v 1.3 2008/05/15 19:45:11 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/chemical-mime-data/chemical-mime-data-0.1.94.ebuild,v 1.4 2009/09/18 14:42:47 betelgeuse Exp $
+
+EAPI="2"
inherit eutils fdo-mime
@@ -18,36 +20,21 @@ DEPEND="dev-util/pkgconfig
dev-util/intltool
dev-util/desktop-file-utils
dev-libs/libxslt
- media-gfx/imagemagick
+ media-gfx/imagemagick[xml]
gnome-base/gnome-mime-data"
RDEPEND=""
-pkg_setup() {
-
- if ! built_with_use 'media-gfx/imagemagick' xml; then
- eerror "media-gfx/imagemagick must be built with the xml USE-flag enabled"
- die "emerge media-gfx/imagemagick with the xml USE-flag enabled"
- fi
-
-}
-
-src_compile() {
-
+src_configure() {
econf --disable-update-database --htmldir=/usr/share/doc/${PN}/html
- emake || die "make failed"
}
src_install() {
-
- make DESTDIR="${D}" install
-
+ emake DESTDIR="${D}" install || die "emake install failed"
}
pkg_postinst() {
-
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
ewarn "You can ignore any 'Unknown media type in type' warnings."
-
}