summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/tilp/files/6.76-makefile.patch')
-rw-r--r--sci-calculators/tilp/files/6.76-makefile.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-calculators/tilp/files/6.76-makefile.patch b/sci-calculators/tilp/files/6.76-makefile.patch
new file mode 100644
index 000000000000..e13924980428
--- /dev/null
+++ b/sci-calculators/tilp/files/6.76-makefile.patch
@@ -0,0 +1,65 @@
+--- /tmp/tilp-6.74/desktop/Makefile.in 2004-06-29 23:02:14.000000000 +0200
++++ ./desktop/Makefile.in 2004-08-14 14:20:51.929766560 +0200
+@@ -331,9 +331,15 @@
+
+
+ install: $(FILES)
++ @mkdir $(DESTDIR)$(sysconfdir);
+ @echo Installing magic local data for file\(1\) command...
+- @if ! grep "\*\*TI85\*\*" /etc/magic; then \
+- cat others/magic >> /etc/magic; \
++ @if ! grep "\*\*TI85\*\*" $(sysconfdir)/magic; \
++ then \
++ mkdir etc; \
++ rm etc/magic; \
++ cp $(sysconfdir)/magic etc/; \
++ cat others/magic >> etc/magic; \
++ $(INSTALL_DATA) etc/magic $(DESTDIR)$(sysconfdir)/magic; \
+ fi;
+ @echo Done.
+
+@@ -345,29 +351,35 @@
+ fi;
+
+ @echo Installing application registry in Gnome...
+- @$(INSTALL) -m644 gnome/tilp.applications /usr/share/application-registry
++ @mkdir -p $(DESTDIR)/usr/share/application-registry/
++ @$(INSTALL) -m644 gnome/tilp.applications $(DESTDIR)/usr/share/application-registry
+
+ @echo Installing file and icons handling in Gnome...
+- @$(INSTALL) -m644 gnome/tilp.keys /usr/share/mime-info
+- @$(INSTALL) -m644 gnome/tilp.mime /usr/share/mime-info
++ @mkdir -p $(DESTDIR)/usr/share/mime-info;
++ @$(INSTALL) -m644 gnome/tilp.keys $(DESTDIR)/usr/share/mime-info
++ @$(INSTALL) -m644 gnome/tilp.mime $(DESTDIR)/usr/share/mime-info
+
+ @echo Installing TiLP menu entry in Gnome...
+- @$(INSTALL) -m644 gnome/TiLP.desktop /usr/share/applications
++ @mkdir -p $(DESTDIR)/usr/share/applications
++ @$(INSTALL) -m644 gnome/TiLP.desktop $(DESTDIR)/usr/share/applications
+ @echo Done.
+
+ @echo "---";
+
+ @echo Installing KMimeMagic local data...
+- @if ! grep "\*\*TI85" /usr/share/mimelnk/magic; then \
+- cat kde/magic >> /usr/share/mimelnk/magic; \
++
++#confusing kde mime type resolution
++# @if ! grep "\*\*TI85" /usr/share/mimelnk/magic; then \
++ cat kde/magic >> $(DESTDIR)/usr/share/mimelnk/magic; \
+ fi;
+
+ @echo Installing TiLP menu entry in KDE...
+- @$(INSTALL) -d /usr/share/applnk/Edutainment/Mathematics
+- @$(INSTALL) -m644 kde/tilp.desktop /usr/share/applnk/Edutainment/Mathematics/
++ @$(INSTALL) -d $(DESTDIR)/usr/share/applnk/Edutainment/Mathematics
++ @$(INSTALL) -m644 kde/tilp.desktop $(DESTDIR)/usr/share/applnk/Edutainment/Mathematics/
+
+ @echo Installing file and icons handling in KDE...
+- @$(INSTALL) -m644 kde/x-tilp.desktop /usr/share/mimelnk/application
++ @mkdir -p $(DESTDIR)/usr/share/mimelnk/application
++ @$(INSTALL) -m644 kde/x-tilp.desktop $(DESTDIR)/usr/share/mimelnk/application
+ @echo Done.
+
+ uninstall: $(FILES)