summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/notmuch/notmuch-0.9.ebuild')
-rw-r--r--net-mail/notmuch/notmuch-0.9.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/net-mail/notmuch/notmuch-0.9.ebuild b/net-mail/notmuch/notmuch-0.9.ebuild
deleted file mode 100644
index 3cf95cfb1443..000000000000
--- a/net-mail/notmuch/notmuch-0.9.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.9.ebuild,v 1.2 2011/11/02 16:48:13 aidecoe Exp $
-
-EAPI=4
-
-inherit autotools-utils elisp-common
-
-DESCRIPTION="The mail indexer"
-HOMEPAGE="http://notmuchmail.org/"
-SRC_URI="${HOMEPAGE}/releases/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion debug emacs vim zsh-completion"
-
-DEPEND="
- >=dev-libs/glib-2.14
- dev-libs/gmime:2.4
- dev-libs/xapian
- sys-libs/talloc
- debug? ( dev-util/valgrind )
- emacs? ( >=virtual/emacs-23 )
- x86? ( >=dev-libs/xapian-1.2.7-r2 )
- vim? ( || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 ) )
- "
-RDEPEND="${DEPEND}
- zsh-completion? ( app-shells/zsh )
- "
-
-DOCS=( AUTHORS NEWS README TODO )
-PATCHES=(
- "${FILESDIR}/${PV}-fix-lib-makefile-local.patch"
- "${FILESDIR}/${PV}-emacsetcdir.patch"
- )
-SITEFILE="50${PN}-gentoo.el"
-
-pkg_setup() {
- if use emacs; then
- elisp-need-emacs 23 || die "Emacs version too low"
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --bashcompletiondir="${ROOT}/usr/share/bash-completion"
- --emacslispdir="${ROOT}/${SITELISP}/${PN}"
- --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
- --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
- $(use_with bash-completion)
- $(use_with emacs)
- $(use_with zsh-completion)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- if use emacs; then
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use vim; then
- insinto /usr/share/vim/vimfiles
- doins -r vim/plugin vim/syntax
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}